p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in gst-plugins-good0.10 · Seite 2

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für gst-plugins-good0.10: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 32

  1. CVE-2024-47539

    Hoch · CVSS 8.6EPSS 1,32%Keine Korrektur veröffentlicht

    GHSL-2024-195: GStreamer has an OOB-write in convert_to_s334_1a

    GStreamer is a library for constructing graphs of media-handling components. An out-of-bounds write vulnerability was identified in the convert_to_s334_1a function in isomp4/qtdemux.c. The vulnerability arises due to a discrepancy between the size of memory allocated to the storage array and the loop condition i * 2 < ccpair_size. Specifically, when ccpair_size is even, the allocated size in storage does not match the loop's expected bounds, resulting in an out-of-bounds write. This bug allows for the overwriting of up to 3 bytes beyond the allocated bounds of the storage array. This vulnerability is fixed in 1.24.10.

    Veröffentlicht Aktualisiert
  2. CVE-2024-47537

    Hoch · CVSS 8.6EPSS 0,96%Keine Korrektur veröffentlicht

    GHSL-2024-094: GStreamer has an OOB-write in isomp4/qtdemux.c

    GStreamer is a library for constructing graphs of media-handling components. The program attempts to reallocate the memory pointed to by stream->samples to accommodate stream->n_samples + samples_count elements of type QtDemuxSample. The problem is that samples_count is read from the input file. And if this value is big enough, this can lead to an integer overflow during the addition. As a consequence, g_try_renew might allocate memory for a significantly smaller number of elements than intended. Following this, the program iterates through samples_count elements and attempts to write samples_count number of elements, potentially exceeding th

    Veröffentlicht Aktualisiert
  3. CVE-2023-37327

    Hoch · CVSS 7.6EPSS 1,7%Keine Korrektur veröffentlicht

    GStreamer FLAC File Parsing Integer Overflow Remote Code Execution Vulnerability

    GStreamer FLAC File Parsing Integer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of FLAC audio files. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before allocating a buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-20775

    Veröffentlicht Aktualisiert
  4. CVE-2017-5840

    Hoch · CVSS 7.5EPSS 4,72%Korrektur verfügbar

    CVE-2017-5840

    The qtdemux_parse_samples function in gst/isomp4/qtdemux.c in gst-plugins-good in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (out-of-bounds heap read) via vectors involving the current stts index.

    • Auf 0.10.31-3+nmu4ubuntu2.16.04.3 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2016-10198

    Mittel · CVSS 5.5EPSS 2,67%Korrektur verfügbar

    CVE-2016-10198

    The gst_aac_parse_sink_setcaps function in gst/audioparsers/gstaacparse.c in gst-plugins-good in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via a crafted audio file.

    • Auf 0.10.31-3+nmu4ubuntu2.16.04.3 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2016-9636

    Kritisch · CVSS 9.8EPSS 8,33%Korrektur verfügbar

    CVE-2016-9636

    Heap-based buffer overflow in the flx_decode_delta_fli function in gst/flx/gstflxdec.c in the FLIC decoder in GStreamer before 1.10.2 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) by providing a 'write count' that goes beyond the initialized buffer.

    • Auf 0.10.31-3+nmu4ubuntu2.16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2016-9635

    Kritisch · CVSS 9.8EPSS 8,84%Korrektur verfügbar

    CVE-2016-9635

    Heap-based buffer overflow in the flx_decode_delta_fli function in gst/flx/gstflxdec.c in the FLIC decoder in GStreamer before 1.10.2 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) by providing a 'skip count' that goes beyond initialized buffer.

    • Auf 0.10.31-3+nmu4ubuntu2.16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2016-9634

    Kritisch · CVSS 9.8EPSS 8,84%Korrektur verfügbar

    CVE-2016-9634

    Heap-based buffer overflow in the flx_decode_delta_fli function in gst/flx/gstflxdec.c in the FLIC decoder in GStreamer before 1.10.2 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via the start_line parameter.

    • Auf 0.10.31-3+nmu4ubuntu2.16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2016-9810

    Mittel · CVSS 5.5EPSS 2,37%Korrektur verfügbar

    CVE-2016-9810

    The gst_decode_chain_free_internal function in the flxdex decoder in gst-plugins-good in GStreamer before 1.10.2 allows remote attackers to cause a denial of service (invalid memory read and crash) via an invalid file, which triggers an incorrect unref call.

    • Auf 0.10.31-3+nmu4ubuntu2.16.04.2 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →