p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in linux-aws-hwe · Seite 14

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für linux-aws-hwe: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 411

  1. CVE-2019-14816

    Mittel · CVSS 5.5EPSS 0,91%Korrektur verfügbar

    CVE-2019-14816

    There is heap-based buffer overflow in kernel, all versions up to, excluding 5.3, in the marvell wifi chip driver in Linux kernel, that allows local users to cause a denial of service(system crash) or possibly execute arbitrary code.

    • Auf 4.15.0-1052.54~16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2019-14821

    Hoch · CVSS 7.5EPSS 0,76%Korrektur verfügbar

    CVE-2019-14821

    An out-of-bounds access issue was found in the Linux kernel, all versions through 5.3, in the way Linux kernel's KVM hypervisor implements the Coalesced MMIO write operation. It operates on an MMIO ring buffer 'struct kvm_coalesced_mmio' object, wherein write indices 'ring->first' and 'ring->last' value could be supplied by a host user-space process. An unprivileged host user or process with access to '/dev/kvm' device could use this flaw to crash the host kernel, resulting in a denial of service or potentially escalating privileges on the system.

    • Auf 4.15.0-1052.54~16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2019-14835

    Hoch · CVSS 7.2EPSS 0,62%Korrektur verfügbar

    CVE-2019-14835

    A buffer overflow flaw was found, in versions from 2.6.34 to 5.2.x, in the way Linux kernel's vhost functionality that translates virtqueue buffers to IOVs, logged the buffer descriptors during migration. A privileged guest user able to pass descriptors with invalid length to the host when migration is underway, could use this flaw to increase their privileges on the host.

    • Auf 4.15.0-1050.52~16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2019-15031

    Mittel · CVSS 4.4EPSS 0,56%Korrektur verfügbar

    CVE-2019-15031

    In the Linux kernel through 5.2.14 on the powerpc platform, a local user can read vector registers of other users' processes via an interrupt. To exploit the venerability, a local user starts a transaction (via the hardware transactional memory instruction tbegin) and then accesses vector registers. At some point, the vector registers will be corrupted with the values from a different local Linux process, because MSR_TM_ACTIVE is misused in arch/powerpc/kernel/process.c.

    • Auf 4.15.0-1050.52~16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2019-15030

    Mittel · CVSS 4.8EPSS 0,45%Korrektur verfügbar

    CVE-2019-15030

    In the Linux kernel through 5.2.14 on the powerpc platform, a local user can read vector registers of other users' processes via a Facility Unavailable exception. To exploit the venerability, a local user starts a transaction (via the hardware transactional memory instruction tbegin) and then accesses vector registers. At some point, the vector registers will be corrupted with the values from a different local Linux process because of a missing arch/powerpc/kernel/process.c check.

    • Auf 4.15.0-1050.52~16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2019-16229

    Mittel · CVSS 4.1EPSS 0,42%Korrektur verfügbar

    CVE-2019-16229

    drivers/gpu/drm/amd/amdkfd/kfd_interrupt.c in the Linux kernel 5.2.14 does not check the alloc_workqueue return value, leading to a NULL pointer dereference. NOTE: The security community disputes this issues as not being serious enough to be deserving a CVE id

    • Auf 4.15.0-1060.62~16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  7. USN-4115-2

    Nicht bewertetKorrektur verfügbar

    linux, linux-aws, linux-aws-hwe, linux-azure, linux-gcp, linux-gke-4.15, linux-hwe, linux-kvm, linux-oracle, linux-raspi2 regression

    USN 4115-1 fixed vulnerabilities in the Linux 4.15 kernel for Ubuntu 18.04 LTS and Ubuntu 16.04 LTS. Unfortunately, as part of the update, a regression was introduced that caused a kernel crash when handling fragmented packets in some situations. This update addresses the issue. We apologize for the inconvenience. Original advisory details: Hui Peng and Mathias Payer discovered that the Option USB High Speed driver in the Linux kernel did not properly validate metadata received from the device. A physically proximate attacker could use this to cause a denial of service (system crash). (CVE-2018-19985) Zhipeng Xie discovered that an i

    • Auf 4.15.0-1048.50~16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2019-9455

    Niedrig · CVSS 2.3EPSS 0,18%Korrektur verfügbar

    CVE-2019-9455

    In the Android kernel in the video driver there is a kernel pointer leak due to a WARN_ON statement. This could lead to local information disclosure with System execution privileges needed. User interaction is not needed for exploitation.

    • Auf 4.15.0-1047.49~16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2019-9453

    Mittel · CVSS 4.4EPSS 0,18%Korrektur verfügbar

    CVE-2019-9453

    In the Android kernel in F2FS touch driver there is a possible out of bounds read due to improper input validation. This could lead to local information disclosure with system execution privileges needed. User interaction is not needed for exploitation.

    • Auf 4.15.0-1047.49~16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  10. CVE-2019-9445

    Mittel · CVSS 4.4EPSS 0,27%Korrektur verfügbar

    CVE-2019-9445

    In the Android kernel in F2FS driver there is a possible out of bounds read due to a missing bounds check. This could lead to local information disclosure with system execution privileges needed. User interaction is not needed for exploitation.

    • Auf 4.15.0-1083.87~16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  11. CVE-2019-9245

    Mittel · CVSS 4.4EPSS 0,18%Korrektur verfügbar

    CVE-2019-9245

    In the Android kernel in the f2fs driver there is a possible out of bounds read due to a missing bounds check. This could lead to local information disclosure with System execution privileges needed. User interaction is not needed for exploitation.

    • Auf 4.15.0-1047.49~16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  12. CVE-2019-9458

    Hoch · CVSS 7.3EPSS 0,17%Korrektur verfügbar

    CVE-2019-9458

    In the Android kernel in the video driver there is a use after free due to a race condition. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.

    • Auf 4.15.0-1047.49~16.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  13. CVE-2019-2182

    Hoch · CVSS 7.8EPSS 0,22%Korrektur verfügbar

    CVE-2019-2182

    In the Android kernel in the kernel MMU code there is a possible execution path leaving some kernel text and rodata pages writable. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.

    • Auf 4.15.0-1063.67~16.04.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →