p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in consul · Seite 2

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für consul: 4. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 46

  1. CVE-2024-10086

    Mittel · CVSS 6.1EPSS 0,4%Keine Korrektur veröffentlicht

    Consul Vulnerable To Reflected XSS On Content-Type Error Manipulation

    A vulnerability was identified in Consul and Consul Enterprise such that the server response did not explicitly set a Content-Type HTTP header, allowing user-provided inputs to be misinterpreted and lead to reflected XSS.

    Veröffentlicht Aktualisiert
  2. CVE-2023-5332

    Mittel · CVSS 5.9EPSS 0,87%Keine Korrektur veröffentlicht

    Dependency on Vulnerable Third-Party Component in GitLab

    Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.

    Veröffentlicht Aktualisiert
  3. CVE-2023-1297

    Mittel · CVSS 4.9EPSS 0,77%Keine Korrektur veröffentlicht

    Consul Cluster Peering can Result in Denial of Service

    Consul and Consul Enterprise's cluster peering implementation contained a flaw whereby a peer cluster with service of the same name as a local service could corrupt Consul state, resulting in denial of service. This vulnerability was resolved in Consul 1.14.5, and 1.15.3

    Veröffentlicht Aktualisiert
  4. CVE-2023-2816

    Hoch · CVSS 8.7EPSS 0,58%Keine Korrektur veröffentlicht

    Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner

    Consul and Consul Enterprise allowed any user with service:write permissions to use Envoy extensions configured via service-defaults to patch remote proxy instances that target the configured service, regardless of whether the user has permission to modify the service(s) corresponding to those modified proxies.

    Veröffentlicht Aktualisiert
  5. CVE-2023-0845

    Mittel · CVSS 4.9EPSS 1%Keine Korrektur veröffentlicht

    Consul Server Panic when Ingress and API Gateways Configured with Peering

    Consul and Consul Enterprise allowed an authenticated user with service:write permissions to trigger a workflow that causes Consul server and client agents to crash under certain circumstances. This vulnerability was fixed in Consul 1.14.5.

    Veröffentlicht Aktualisiert
  6. CVE-2022-3920

    Mittel · CVSS 5.3EPSS 0,72%Keine Korrektur veröffentlicht

    Consul Peering Imported Nodes/Services Leak

    HashiCorp Consul and Consul Enterprise 1.13.0 up to 1.13.3 do not filter cluster filtering's imported nodes and services for HTTP or RPC endpoints used by the UI. Fixed in 1.14.0.

    Veröffentlicht Aktualisiert
  7. CVE-2022-40716

    Mittel · CVSS 6.5EPSS 1,09%Keine Korrektur veröffentlicht

    CVE-2022-40716

    HashiCorp Consul and Consul Enterprise up to 1.11.8, 1.12.4, and 1.13.1 do not check for multiple SAN URI values in a CSR on the internal RPC endpoint, enabling leverage of privileged access to bypass service mesh intentions. Fixed in 1.11.9, 1.12.5, and 1.13.2."

    Veröffentlicht Aktualisiert
  8. CVE-2022-24687

    Mittel · CVSS 6.5EPSS 1,49%Keine Korrektur veröffentlicht

    CVE-2022-24687

    HashiCorp Consul and Consul Enterprise 1.9.0 through 1.9.14, 1.10.7, and 1.11.2 clusters with at least one Ingress Gateway allow a user with service:write to register a specifically-defined service that can cause Consul servers to panic. Fixed in 1.9.15, 1.10.8, and 1.11.3.

    Veröffentlicht Aktualisiert
  9. CVE-2021-41805

    Hoch · CVSS 8.8EPSS 34,79%Keine Korrektur veröffentlicht

    CVE-2021-41805

    HashiCorp Consul Enterprise before 1.8.17, 1.9.x before 1.9.11, and 1.10.x before 1.10.4 has Incorrect Access Control. An ACL token (with the default operator:write permissions) in one namespace can be used for unintended privilege escalation in a different namespace.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →