p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in jackson-databind · Seite 4

In den letzten 30 Tagen veröffentlichte Sicherheitslücke für jackson-databind: 1. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 69

  1. CVE-2019-14439

    Hoch · CVSS 7.5EPSS 10,85%Keine Korrektur veröffentlicht

    CVE-2019-14439

    A Polymorphic Typing issue was discovered in FasterXML jackson-databind 2.x before 2.9.9.2. This occurs when Default Typing is enabled (either globally or for a specific property) for an externally exposed JSON endpoint and the service has the logback jar in the classpath.

    Veröffentlicht Aktualisiert
  2. CVE-2019-12814

    Mittel · CVSS 5.9EPSS 10,9%Keine Korrektur veröffentlicht

    CVE-2019-12814

    A Polymorphic Typing issue was discovered in FasterXML jackson-databind 2.x through 2.9.9. When Default Typing is enabled (either globally or for a specific property) for an externally exposed JSON endpoint and the service has JDOM 1.x or 2.x jar in the classpath, an attacker can send a specifically crafted JSON message that allows them to read arbitrary local files on the server.

    Veröffentlicht Aktualisiert
  3. CVE-2019-12086

    Hoch · CVSS 7.5EPSS 21,95%Keine Korrektur veröffentlicht

    CVE-2019-12086

    A Polymorphic Typing issue was discovered in FasterXML jackson-databind 2.x before 2.9.9. When Default Typing is enabled (either globally or for a specific property) for an externally exposed JSON endpoint, the service has the mysql-connector-java jar (8.0.14 or earlier) in the classpath, and an attacker can host a crafted MySQL server reachable by the victim, an attacker can send a crafted JSON message that allows them to read arbitrary local files on the server. This occurs because of missing com.mysql.cj.jdbc.admin.MiniAdmin validation.

    Veröffentlicht Aktualisiert
  4. CVE-2018-1000873

    Mittel · CVSS 6.5EPSS 4,76%Keine Korrektur veröffentlicht

    CVE-2018-1000873

    Fasterxml Jackson version Before 2.9.8 contains a CWE-20: Improper Input Validation vulnerability in Jackson-Modules-Java8 that can result in Causes a denial-of-service (DoS). This attack appear to be exploitable via The victim deserializes malicious input, specifically very large values in the nanoseconds field of a time value. This vulnerability appears to have been fixed in 2.9.8.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →