p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in webkit2gtk · Seite 27

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für webkit2gtk: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 548

  1. CVE-2019-6216

    Hoch · CVSS 8.8EPSS 1,84%Korrektur verfügbar

    CVE-2019-6216

    Multiple memory corruption issues were addressed with improved memory handling. This issue is fixed in iOS 12.1.3, tvOS 12.1.2, watchOS 5.1.3, Safari 12.0.3, iTunes 12.9.3 for Windows, iCloud for Windows 7.10. Processing maliciously crafted web content may lead to arbitrary code execution.

    • Auf 2.22.5-0ubuntu0.18.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2019-6215

    Hoch · CVSS 8.8EPSS 9,75%Öffentlicher ExploitKorrektur verfügbar

    CVE-2019-6215

    A type confusion issue was addressed with improved memory handling. This issue is fixed in iOS 12.1.3, tvOS 12.1.2, Safari 12.0.3, iTunes 12.9.3 for Windows, iCloud for Windows 7.10. Processing maliciously crafted web content may lead to arbitrary code execution.

    • Auf 2.22.6-0ubuntu0.18.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2019-6212

    Hoch · CVSS 8.8EPSS 1,86%Korrektur verfügbar

    CVE-2019-6212

    Multiple memory corruption issues were addressed with improved memory handling. This issue is fixed in iOS 12.1.3, tvOS 12.1.2, Safari 12.0.3, iTunes 12.9.3 for Windows, iCloud for Windows 7.10. Processing maliciously crafted web content may lead to arbitrary code execution.

    • Auf 2.22.6-0ubuntu0.18.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2019-8375

    Kritisch · CVSS 9.8EPSS 15,7%Öffentlicher ExploitKorrektur verfügbar

    CVE-2019-8375

    The UIProcess subsystem in WebKit, as used in WebKitGTK through 2.23.90 and WebKitGTK+ through 2.22.6 and other products, does not prevent the script dialog size from exceeding the web view size, which allows remote attackers to cause a denial of service (Buffer Overflow) or possibly have unspecified other impact, related to UIProcess/API/gtk/WebKitScriptDialogGtk.cpp, UIProcess/API/gtk/WebKitScriptDialogImpl.cpp, and UIProcess/API/gtk/WebKitWebViewGtk.cpp, as demonstrated by GNOME Web (aka Epiphany).

    • Auf 2.24.1-0ubuntu0.18.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2019-6251

    Hoch · CVSS 8.1EPSS 4,26%Korrektur verfügbar

    CVE-2019-6251

    WebKitGTK and WPE WebKit prior to version 2.24.1 are vulnerable to address bar spoofing upon certain JavaScript redirections. An attacker could cause malicious web content to be displayed as if for a trusted URI. This is similar to the CVE-2018-8383 issue in Microsoft Edge.

    • Auf 2.24.1-0ubuntu0.18.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2018-4278

    Mittel · CVSS 4.3EPSS 2,28%Korrektur verfügbar

    CVE-2018-4278

    In Safari before 11.1.2, iTunes before 12.8 for Windows, iOS before 11.4.1, tvOS before 11.4.1, iCloud for Windows before 7.6, sound fetched through audio elements may be exfiltrated cross-origin. This issue was addressed with improved audio taint tracking.

    • Auf 2.20.5-0ubuntu0.18.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  7. USN-3781-2

    Nicht bewertetKorrektur verfügbar

    webkit2gtk regression

    USN-3781-1 fixed vulnerabilities in WebKitGTK+. The updated package was missing some header files, preventing certain applications from building. This update fixes the problem. We apologize for the inconvenience. Original advisory details: A large number of security issues were discovered in the WebKitGTK+ Web and JavaScript engines. If a user were tricked into viewing a malicious website, a remote attacker could exploit a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.

    • Auf 2.22.2-0ubuntu0.18.04.2 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2018-12293

    Hoch · CVSS 8.8EPSS 10,03%Öffentlicher ExploitKorrektur verfügbar

    CVE-2018-12293

    The getImageData function in the ImageBufferCairo class in WebCore/platform/graphics/cairo/ImageBufferCairo.cpp in WebKit, as used in WebKitGTK+ prior to version 2.20.3 and WPE WebKit prior to version 2.20.1, is vulnerable to a heap-based buffer overflow triggered by an integer overflow, which could be abused by crafted HTML content.

    • Auf 2.20.3-0ubuntu0.18.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2018-4246

    Hoch · CVSS 8.8EPSS 2,97%Korrektur verfügbar

    CVE-2018-4246

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code via a crafted web site that leverages type confusion.

    • Auf 2.20.5-0ubuntu0.18.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  10. CVE-2018-4233

    Hoch · CVSS 8.8EPSS 53,82%Öffentlicher ExploitKorrektur verfügbar

    CVE-2018-4233

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site.

    • Auf 2.20.3-0ubuntu0.18.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  11. CVE-2018-4232

    Mittel · CVSS 4.3EPSS 2,08%Korrektur verfügbar

    CVE-2018-4232

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. The issue involves the "WebKit" component. It allows remote attackers to overwrite cookies via a crafted web site.

    • Auf 2.20.3-0ubuntu0.18.04.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →