p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in cups · Seite 2

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für cups: 9. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 27

  1. CVE-2025-58436

    Mittel · CVSS 5.1EPSS 0,23%Korrektur verfügbar

    OpenPrinting CUPS slow client can halt cupsd, leading to a possible DoS attack

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a client that connects to cupsd but sends slow messages, e.g. only one byte per second, delays cupsd as a whole, such that it becomes unusable by other clients. This issue has been patched in version 2.4.15.

    • Auf 2.4.7-1.2ubuntu7.9 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2025-61915

    Mittel · CVSS 6EPSS 0,46%Korrektur verfügbar

    OpenPrinting CUPS vulnerable to stack based out-of-bound write

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.

    • Auf 2.4.7-1.2ubuntu7.7 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2025-58364

    Mittel · CVSS 6.5EPSS 1,16%Korrektur verfügbar

    cups: Remote DoS via null dereference

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.12 and earlier, an unsafe deserialization and validation of printer attributes causes null dereference in the libcups library. This is a remote DoS vulnerability available in local subnet in default configurations. It can cause the cups & cups-browsed to crash, on all the machines in local network who are listening for printers (so by default for all regular linux machines). On systems where the vulnerability CVE-2024-47176 (cups-filters 1.x/cups-browsed 2.x vulnerability) was not fixed, and the firewall on the machine does not

    • Auf 2.4.7-1.2ubuntu7.4 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2025-58060

    Hoch · CVSS 8EPSS 1%Korrektur verfügbar

    cups has Authentication bypass with AuthType Negotiate

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.12 and earlier, when the `AuthType` is set to anything but `Basic`, if the request contains an `Authorization: Basic ...` header, the password is not checked. This results in authentication bypass. Any configuration that allows an `AuthType` that is not `Basic` is affected. Version 2.4.13 fixes the issue.

    • Auf 2.4.7-1.2ubuntu7.4 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2024-47175

    Hoch · CVSS 8.6EPSS 63,61%Öffentlicher ExploitKorrektur verfügbar

    libppd's ppdCreatePPDFromIPP2 function does not sanitize IPP attributes when creating the PPD buffer

    CUPS is a standards-based, open-source printing system, and `libppd` can be used for legacy PPD file support. The `libppd` function `ppdCreatePPDFromIPP2` does not sanitize IPP attributes when creating the PPD buffer. When used in combination with other functions such as `cfGetPrinterAttributes5`, can result in user controlled input and ultimately code execution via Foomatic. This vulnerability can be part of an exploit chain leading to remote code execution (RCE), as described in CVE-2024-47176.

    • Auf 2.4.7-1.2ubuntu7.3 aktualisieren
    Veröffentlicht Aktualisiert
  6. USN-6844-2

    Nicht bewertetKorrektur verfügbar

    cups regression

    USN-6844-1 fixed vulnerabilities in the CUPS package. The update lead to the discovery of a regression in CUPS with regards to how the cupsd daemon handles Listen configuration directive. This update fixes the problem. We apologize for the inconvenience. Original advisory details: Rory McNamara discovered that when starting the cupsd server with a Listen configuration item, the cupsd process fails to validate if bind call passed. An attacker could possibly trick cupsd to perform an arbitrary chmod of the provided argument, providing world-writable access to the target.

    • Auf 2.4.7-1.2ubuntu7.2 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2024-35235

    Mittel · CVSS 4.4EPSS 2,42%Korrektur verfügbar

    Cupsd Listen arbitrary chmod 0140777

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.8 and earlier, when starting the cupsd server with a Listen configuration item pointing to a symbolic link, the cupsd process can be caused to perform an arbitrary chmod of the provided argument, providing world-writable access to the target. Given that cupsd is often running as root, this can result in the change of permission of any user or system files to be world writable. Given the aforementioned Ubuntu AppArmor context, on such systems this vulnerability is limited to those files modifiable by the cupsd process. In that s

    • Auf 2.4.7-1.2ubuntu7.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →