p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in tomcat9 · Seite 3

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für tomcat9: 8. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 49

  1. CVE-2026-43514

    Niedrig · CVSS 3.7EPSS 0,35%Keine Korrektur veröffentlicht

    Apache Tomcat: AJP secret compared in non-constant time

    Observable Timing Discrepancy vulnerability when comparing AJP secret in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Older unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

    Veröffentlicht Aktualisiert
  2. CVE-2026-34487

    Hoch · CVSS 7.5EPSS 0,45%Keine Korrektur veröffentlicht

    Apache Tomcat: Cloud membership for clustering component exposed the Kubernetes bearer token

    Insertion of Sensitive Information into Log File vulnerability in the cloud membership for clustering component of Apache Tomcat exposed the Kubernetes bearer token. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.20, from 10.1.0-M1 through 10.1.53, from 9.0.13 through 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fix the issue.

    Veröffentlicht Aktualisiert
  3. CVE-2026-29146

    Hoch · CVSS 7.5EPSS 8,85%Öffentlicher ExploitKeine Korrektur veröffentlicht

    Apache Tomcat: EncryptInterceptor vulnerable to padding oracle attack by default

    Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

    Veröffentlicht Aktualisiert
  4. CVE-2026-25854

    Mittel · CVSS 6.1EPSS 0,53%Keine Korrektur veröffentlicht

    Apache Tomcat: Occasionally open redirect

    Occasional URL redirection to untrusted Site ('Open Redirect') vulnerability in Apache Tomcat via the LoadBalancerDrainingValve. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M1 through 10.1.52, from 9.0.0.M23 through 9.0.115, from 8.5.30 through 8.5.100. Other, unsupported versions may also be affected Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

    Veröffentlicht Aktualisiert
  5. CVE-2026-24880

    Hoch · CVSS 7.5EPSS 0,7%Keine Korrektur veröffentlicht

    Apache Tomcat: Request smuggling via invalid chunk extension

    Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache Tomcat via invalid chunk extension. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M1 through 10.1.52, from 9.0.0.M1 through 9.0.115, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other, unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.20, 10.1.52 or 9.0.116, which fix the issue.

    Veröffentlicht Aktualisiert
  6. CVE-2026-24733

    Mittel · CVSS 6.5EPSS 0,55%Keine Korrektur veröffentlicht

    Apache Tomcat: Security constraint bypass with HTTP/0.9

    Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

    Veröffentlicht Aktualisiert
  7. CVE-2025-66614

    Hoch · CVSS 7.6EPSS 0,27%Keine Korrektur veröffentlicht

    Apache Tomcat: Client certificate verification bypass due to virtual host mapping

    Improper Input Validation vulnerability. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0-M1 through 9.0.112. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Older EOL versions are not affected. Tomcat did not validate that the host name provided via the SNI extension was the same as the host name provided in the HTTP host header field. If Tomcat was configured with more than one virtual host and the TLS configuration for one of those hosts did not require client certificate authentication but another one did

    Veröffentlicht Aktualisiert
  8. CVE-2024-50379

    Kritisch · CVSS 9.8EPSS 31,82%Öffentlicher ExploitKeine Korrektur veröffentlicht

    Apache Tomcat: RCE due to TOCTOU issue in JSP compilation

    Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability during JSP compilation in Apache Tomcat permits an RCE on case insensitive file systems when the default servlet is enabled for write (non-default configuration). This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.0.97. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.2, 10.1.34 or 9.0.98, which fixes the issue.

    Veröffentlicht Aktualisiert
  9. CVE-2023-46589

    Hoch · CVSS 7.5EPSS 2,65%Korrektur verfügbar

    Apache Tomcat: HTTP request smuggling via malformed trailer headers

    Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.

    • Auf 9.0.70-2ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →