p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in mariadb · Seite 7

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für mariadb: 89. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 126

  1. CVE-2026-44173

    Mittel · CVSS 5EPSS 0,62%Korrektur verfügbar

    MariaDB: FILE privilege was not checked for subqueries in the FROM clause

    MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, MariaDB allowed SELECT ... INTO OUTFILE and SELECT ... INTO DUMPFILE without verifying the FILE privilege if the FROM clause contained only subqueries. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

    • Auf 1:11.8.6-5ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-44172

    Mittel · CVSS 6.9EPSS 1,04%Korrektur verfügbar

    MariaDB: mysql_real_escape_string() incorrectly handled big5

    MariaDB server is a community developed fork of MySQL server. In versions 3.3.18 and 3.4.8, an application that was taking non-validated user input, escaping it with mysql_real_escape_string() and sending it to the database using text protocol and big5 character set was vulnerable to SQL injections, even though mysql_real_escape_string() was supposed to prevent them. This issue has been patched in versions 3.3.19 and 3.4.9.

    • Auf 1:11.8.6-5ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2026-44171

    Mittel · CVSS 6.3EPSS 0,19%Korrektur verfügbar

    MariaDB: path traversal in mbstream

    MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, mbstream did not check for /../ in the path when unpacking the archive. A proper backup can never contain such paths, but a specially crafted archive could have caused mbstream to create files outside of the target-dir path. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

    • Auf 1:11.8.6-5ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2026-44169

    Mittel · CVSS 4.3EPSS 0,24%Korrektur verfügbar

    MariaDB: Authorization bypass in role-based routine-level privilege check exposes stored routine definitions

    MariaDB server is a community developed fork of MySQL server. From versions 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, a user getting EXECUTE access to a stored routine via a role, could see the routine definition even without SHOW CREATE ROUTINE privilege. This issue has been patched in versions 11.4.11, 11.8.7, and 12.3.2.

    • Auf 1:11.8.6-5ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2026-44168

    Hoch · CVSS 8EPSS 0,59%Korrektur verfügbar

    MariaDB: wsrep SST unsafe parameter handling on the donor side

    MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, during the SST the donor node is interpolating parameters that the joiner sent into the command line. Not all parameters were properly validated which could allow a malicious joiner to execute arbitrary shell commands on the donor side via the mariabackup SST method. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

    • Auf 1:11.8.6-5ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2026-49261

    Kritisch · CVSS 10EPSS 1,58%Korrektur verfügbar

    MariaDB server has unsafe parameter handling in `wsrep_notify_cmd`

    MariaDB server is a community developed fork of MySQL server. Versions 10.6.1 through 10.6.26, 10.11.1 through 10.11.17, 11.4.1 through 11.4.11, 11.8.1 through 11.8.7, and 12.3.1 with `wsrep_notify_cmd` enabled would execute shell commands embedded in the name of the joiner node. This is fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2. As a workaround, anyone who cannot upgrade now should disable `wsrep_notify_cmd`.

    • Auf 1:11.8.6-5ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →