p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in mediawiki · Seite 6

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für mediawiki: 11. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 163

  1. CVE-2025-32697

    Niedrig · CVSS 0EPSS 0,39%Keine Korrektur veröffentlicht

    Cascading protection is not preventing file reversions

    Improper Preservation of Permissions vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/editpage/IntroMessageBuilder.Php, includes/Permissions/PermissionManager.Php, includes/Permissions/RestrictionStore.Php. This issue affects MediaWiki: before 1.42.6, 1.43.1.

    Veröffentlicht Aktualisiert
  2. CVE-2025-32696

    Niedrig · CVSS 0EPSS 0,36%Keine Korrektur veröffentlicht

    "reupload-own" restriction can be bypassed by reverting file

    Improper Preservation of Permissions vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/actions/RevertAction.Php, includes/api/ApiFileRevert.Php. This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.

    Veröffentlicht Aktualisiert
  3. CVE-2025-3469

    Niedrig · CVSS 0EPSS 0,44%Keine Korrektur veröffentlicht

    i18n XSS vulnerability in HTMLMultiSelectField when sections are used

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/htmlform/fields/HTMLMultiSelectField.Php. This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.

    Veröffentlicht Aktualisiert
  4. CVE-2024-47913

    Mittel · CVSS 5.3EPSS 0,45%Keine Korrektur veröffentlicht

    CVE-2024-47913

    An issue was discovered in the AbuseFilter extension for MediaWiki before 1.39.9, 1.40.x and 1.41.x before 1.41.3, and 1.42.x before 1.42.2. An API caller can match a filter condition against AbuseFilter logs even if the caller is not authorized to view the log details for the filter.

    Veröffentlicht Aktualisiert
  5. CVE-2024-36123

    Mittel · CVSS 6.5EPSS 0,47%Keine Korrektur veröffentlicht

    Citizen has a Stored Cross-Site Scripting Vulnerability by editing MediaWiki:Tagline

    Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. The page `MediaWiki:Tagline` has its contents used unescaped, so custom HTML (including Javascript) can be injected by someone with the ability to edit the MediaWiki namespace (typically those with the `editinterface` permission, or sysops). This vulnerability is fixed in 2.16.0.

    Veröffentlicht Aktualisiert
  6. CVE-2023-45362

    Mittel · CVSS 4.3EPSS 0,78%Keine Korrektur veröffentlicht

    CVE-2023-45362

    An issue was discovered in DifferenceEngine.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. diff-multi-sameuser (aka "X intermediate revisions by the same user not shown") ignores username suppression. This is an information leak.

    Veröffentlicht Aktualisiert
  7. CVE-2023-45364

    Mittel · CVSS 5.3EPSS 0,5%Keine Korrektur veröffentlicht

    CVE-2023-45364

    An issue was discovered in includes/page/Article.php in MediaWiki 1.36.x through 1.39.x before 1.39.5 and 1.40.x before 1.40.1. Deleted revision existence is leaked due to incorrect permissions being checked. This reveals that a given revision ID belonged to the given page title, and its timestamp, both of which are not supposed to be public information.

    Veröffentlicht Aktualisiert
  8. CVE-2023-45363

    Hoch · CVSS 7.5EPSS 23,78%Keine Korrektur veröffentlicht

    CVE-2023-45363

    An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. It allows attackers to cause a denial of service (unbounded loop and RequestTimeoutException) when querying pages redirected to other variants with redirects and converttitles set.

    Veröffentlicht Aktualisiert
  9. CVE-2023-3550

    Hoch · CVSS 7.3EPSS 1,38%Keine Korrektur veröffentlicht

    Stored XSS leads to privilege escalation in MediaWiki v1.40.0

    Mediawiki v1.40.0 does not validate namespaces used in XML files. Therefore, if the instance administrator allows XML file uploads, a remote attacker with a low-privileged user account can use this exploit to become an administrator by sending a malicious link to the instance administrator.

    Veröffentlicht Aktualisiert
  10. CVE-2023-37302

    Mittel · CVSS 6.1EPSS 0,69%Keine Korrektur veröffentlicht

    CVE-2023-37302

    An issue was discovered in SiteLinksView.php in Wikibase in MediaWiki through 1.39.3. There is XSS via a crafted badge title attribute. This is also related to lack of escaping in wbTemplate (from resources/wikibase/templates.js) for quotes (which can be in a title attribute).

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →