p PatchFirst

ALPINE-CVE-2023-23936

ALPINE-CVE-2023-23936

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Undici is an HTTP/1.1 client for Node.js. Starting with version 2.0.0 and prior to version 5.19.1, the undici library does not protect `host` HTTP header from CRLF injection vulnerabilities. This issue is patched in Undici v5.19.1. As a workaround, sanitize the `headers.host` string before passing to undici.

CVSS 5.4 · Media · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • nodejs Alpine:v3.15

    Intervalos de versiones afectados
    • ECOSYSTEM: < 16.19.1-r0

    Actualiza a 16.19.1-r0

  • nodejs Alpine:v3.16

    Intervalos de versiones afectados
    • ECOSYSTEM: < 16.19.1-r0

    Actualiza a 16.19.1-r0

  • nodejs Alpine:v3.17

    Intervalos de versiones afectados
    • ECOSYSTEM: < 18.14.1-r0

    Actualiza a 18.14.1-r0

  • nodejs Alpine:v3.18

    Intervalos de versiones afectados
    • ECOSYSTEM: < 18.14.1-r0

    Actualiza a 18.14.1-r0

  • nodejs Alpine:v3.19

    Intervalos de versiones afectados
    • ECOSYSTEM: < 18.14.1-r0

    Actualiza a 18.14.1-r0

  • nodejs Alpine:v3.20

    Intervalos de versiones afectados
    • ECOSYSTEM: < 18.14.1-r0

    Actualiza a 18.14.1-r0

  • nodejs Alpine:v3.21

    Intervalos de versiones afectados
    • ECOSYSTEM: < 18.14.1-r0

    Actualiza a 18.14.1-r0

  • nodejs Alpine:v3.22

    Intervalos de versiones afectados
    • ECOSYSTEM: < 18.14.1-r0

    Actualiza a 18.14.1-r0

  • nodejs Alpine:v3.23

    Intervalos de versiones afectados
    • ECOSYSTEM: < 18.14.1-r0

    Actualiza a 18.14.1-r0

  • nodejs Alpine:v3.24

    Intervalos de versiones afectados
    • ECOSYSTEM: < 18.14.1-r0

    Actualiza a 18.14.1-r0

Fuentes originales

Comprueba tu servidor →