p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de apache2

Vulnerabilidades publicadas para apache2 en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 44

  1. ALPINE-CVE-2021-31618

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2021-31618

    Apache HTTP Server protocol handler for the HTTP/2 protocol checks received request headers against the size limitations as configured for the server and used for the HTTP/1 protocol as well. On violation of these restrictions and HTTP response is sent to the client with a status code indicating why the request was rejected. This rejection response was not fully initialised in the HTTP/2 protocol handler if the offending header was the very first one received or appeared in a a footer. This led to a NULL pointer dereference on initialised memory, crashing reliably the child process. Since such a triggering HTTP/2 request is easy to craft and

    • Actualiza a 2.4.48-r0
    Publicación Actualización
  2. ALPINE-CVE-2020-35452

    Alta · CVSS 7.3Corrección disponible

    ALPINE-CVE-2020-35452

    Apache HTTP Server versions 2.4.0 to 2.4.46 A specially crafted Digest nonce can cause a stack overflow in mod_auth_digest. There is no report of this overflow being exploitable, nor the Apache HTTP Server team could create one, though some particular compiler and/or compilation option might make it possible, with limited consequences anyway due to the size (a single byte) and the value (zero byte) of the overflow

    • Actualiza a 2.4.48-r0
    Publicación Actualización
  3. ALPINE-CVE-2020-13950

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2020-13950

    Apache HTTP Server versions 2.4.41 to 2.4.46 mod_proxy_http can be made to crash (NULL pointer dereference) with specially crafted requests using both Content-Length and Transfer-Encoding headers, leading to a Denial of Service

    • Actualiza a 2.4.48-r0
    Publicación Actualización
  4. ALPINE-CVE-2020-9490

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2020-9490

    Apache HTTP Server versions 2.4.20 to 2.4.43. A specially crafted value for the 'Cache-Digest' header in a HTTP/2 request would result in a crash when the server actually tries to HTTP/2 PUSH a resource afterwards. Configuring the HTTP/2 feature via "H2Push off" will mitigate this vulnerability for unpatched servers.

    • Actualiza a 2.4.46-r0
    Publicación Actualización
  5. ALPINE-CVE-2020-11993

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2020-11993

    Apache HTTP Server versions 2.4.20 to 2.4.43 When trace/debug was enabled for the HTTP/2 module and on certain traffic edge patterns, logging statements were made on the wrong connection, causing concurrent use of memory pools. Configuring the LogLevel of mod_http2 above "info" will mitigate this vulnerability for unpatched servers.

    • Actualiza a 2.4.46-r0
    Publicación Actualización
  6. ALPINE-CVE-2019-17657

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2019-17657

    An Uncontrolled Resource Consumption vulnerability in Fortinet FortiSwitch below 3.6.11, 6.0.6 and 6.2.2, FortiAnalyzer below 6.2.3, FortiManager below 6.2.3 and FortiAP-S/W2 below 6.2.2 may allow an attacker to cause admin webUI denial of service (DoS) via handling special crafted HTTP requests/responses in pieces slowly, as demonstrated by Slow HTTP DoS Attacks.

    • Actualiza a 2.4.48-r0
    Publicación Actualización
  7. ALPINE-CVE-2020-1927

    Media · CVSS 6.1Corrección disponible

    ALPINE-CVE-2020-1927

    In Apache HTTP Server 2.4.0 to 2.4.41, redirects configured with mod_rewrite that were intended to be self-referential might be fooled by encoded newlines and redirect instead to an an unexpected URL within the request URL.

    • Actualiza a 2.4.43-r0
    Publicación Actualización
  8. ALPINE-CVE-2019-10097

    Alta · CVSS 7.2Corrección disponible

    ALPINE-CVE-2019-10097

    In Apache HTTP Server 2.4.32-2.4.39, when mod_remoteip was configured to use a trusted intermediary proxy server using the "PROXY" protocol, a specially crafted PROXY header could trigger a stack buffer overflow or NULL pointer deference. This vulnerability could only be triggered by a trusted proxy and not by untrusted HTTP clients.

    • Actualiza a 2.4.41-r0
    Publicación Actualización
  9. ALPINE-CVE-2019-10092

    Media · CVSS 6.1Corrección disponible

    ALPINE-CVE-2019-10092

    In Apache HTTP Server 2.4.0-2.4.39, a limited cross-site scripting issue was reported affecting the mod_proxy error page. An attacker could cause the link on the error page to be malformed and instead point to a page of their choice. This would only be exploitable where a server was set up with proxying enabled but was misconfigured in such a way that the Proxy Error page was displayed.

    • Actualiza a 2.4.41-r0
    Publicación Actualización
  10. ALPINE-CVE-2019-10098

    Media · CVSS 6.1Corrección disponible

    ALPINE-CVE-2019-10098

    In Apache HTTP server 2.4.0 to 2.4.39, Redirects configured with mod_rewrite that were intended to be self-referential might be fooled by encoded newlines and redirect instead to an unexpected URL within the request URL.

    • Actualiza a 2.4.41-r0
    Publicación Actualización
  11. ALPINE-CVE-2019-10081

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2019-10081

    HTTP/2 (2.4.20 through 2.4.39) very early pushes, for example configured with "H2PushResource", could lead to an overwrite of memory in the pushing request's pool, leading to crashes. The memory copied is that of the configured push link header values, not data supplied by the client.

    • Actualiza a 2.4.41-r0
    Publicación Actualización
  12. ALPINE-CVE-2019-9517

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2019-9517

    Some HTTP/2 implementations are vulnerable to unconstrained interal data buffering, potentially leading to a denial of service. The attacker opens the HTTP/2 window so the peer can send without constraint; however, they leave the TCP window closed so the peer cannot actually write (many of) the bytes on the wire. The attacker then sends a stream of requests for a large response object. Depending on how the servers queue the responses, this can consume excess memory, CPU, or both.

    • Actualiza a 2.4.41-r0
    Publicación Actualización
  13. ALPINE-CVE-2019-0197

    Media · CVSS 4.2Corrección disponible

    ALPINE-CVE-2019-0197

    A vulnerability was found in Apache HTTP Server 2.4.34 to 2.4.38. When HTTP/2 was enabled for a http: host or H2Upgrade was enabled for h2 on a https: host, an Upgrade request from http/1.1 to http/2 that was not the first request on a connection could lead to a misconfiguration and crash. Server that never enabled the h2 protocol or that only enabled it for https: and did not set "H2Upgrade on" are unaffected by this issue.

    • Actualiza a 2.4.39-r0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →