p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de python2

Vulnerabilidades publicadas para python2 en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 8

  1. ALPINE-CVE-2019-5010

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2019-5010

    An exploitable denial-of-service vulnerability exists in the X509 certificate parser of Python.org Python 2.7.11 / 3.6.6. A specially crafted X509 certificate can cause a NULL pointer dereference, resulting in a denial of service. An attacker can initiate or accept TLS connections using crafted certificates to trigger this vulnerability.

    • Actualiza a 2.7.15-r3
    Publicación Actualización
  2. ALPINE-CVE-2019-18348

    Media · CVSS 6.1Corrección disponible

    ALPINE-CVE-2019-18348

    An issue was discovered in urllib2 in Python 2.x through 2.7.17 and urllib in Python 3.x through 3.8.0. CRLF injection is possible if the attacker controls a url parameter, as demonstrated by the first argument to urllib.request.urlopen with \r\n (specifically in the host component of a URL) followed by an HTTP header. This is similar to the CVE-2019-9740 query string issue and the CVE-2019-9947 path string issue. (This is not exploitable when glibc has CVE-2016-10739 fixed.). This is fixed in: v2.7.18, v2.7.18rc1; v3.5.10, v3.5.10rc1; v3.6.11, v3.6.11rc1, v3.6.12; v3.7.8, v3.7.8rc1, v3.7.9; v3.8.3, v3.8.3rc1, v3.8.4, v3.8.4rc1, v3.8.5, v3.8.

    • Actualiza a 2.7.18-r0
    Publicación Actualización
  3. ALPINE-CVE-2019-15903

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2019-15903

    In libexpat before 2.2.8, crafted XML input could fool the parser into changing from DTD parsing to document parsing too early; a consecutive call to XML_GetCurrentLineNumber (or XML_GetCurrentColumnNumber) then resulted in a heap-based buffer over-read.

    • Actualiza a 2.7.17-r0
    Publicación Actualización
  4. ALPINE-CVE-2019-9948

    Crítica · CVSS 9.1Corrección disponible

    ALPINE-CVE-2019-9948

    urllib in Python 2.x through 2.7.16 supports the local_file: scheme, which makes it easier for remote attackers to bypass protection mechanisms that blacklist file: URIs, as demonstrated by triggering a urllib.urlopen('local_file:///etc/passwd') call.

    • Actualiza a 2.7.16-r1
    Publicación Actualización
  5. ALPINE-CVE-2019-9636

    Crítica · CVSS 9.8Corrección disponible

    ALPINE-CVE-2019-9636

    Python 2.7.x through 2.7.16 and 3.x through 3.7.2 is affected by: Improper Handling of Unicode Encoding (with an incorrect netloc) during NFKC normalization. The impact is: Information disclosure (credentials, cookies, etc. that are cached against a given hostname). The components are: urllib.parse.urlsplit, urllib.parse.urlparse. The attack vector is: A specially crafted URL could be incorrectly parsed to locate cookies or authentication data and send that information to a different host than when parsed correctly. This is fixed in: v2.7.17, v2.7.17rc1, v2.7.18, v2.7.18rc1; v3.5.10, v3.5.10rc1, v3.5.7, v3.5.8, v3.5.8rc1, v3.5.8rc2, v3.5.9; v

    • Actualiza a 2.7.16-r1
    Publicación Actualización
  6. ALPINE-CVE-2018-14647

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2018-14647

    Python's elementtree C accelerator failed to initialise Expat's hash salt during initialization. This could make it easy to conduct denial of service attacks against Expat by constructing an XML document that would cause pathological hash collisions in Expat's internal data structures, consuming large amounts CPU and RAM. The vulnerability exists in Python versions 3.7.0, 3.6.0 through 3.6.6, 3.5.0 through 3.5.6, 3.4.0 through 3.4.9, 2.7.0 through 2.7.15.

    • Actualiza a 2.7.16-r0
    Publicación Actualización
  7. ALPINE-CVE-2018-1061

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2018-1061

    python before versions 2.7.15, 3.4.9, 3.5.6rc1, 3.6.5rc1 and 3.7.0 is vulnerable to catastrophic backtracking in the difflib.IS_LINE_JUNK method. An attacker could use this flaw to cause denial of service.

    • Actualiza a 2.7.15-r0
    Publicación Actualización
  8. ALPINE-CVE-2018-1060

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2018-1060

    python before versions 2.7.15, 3.4.9, 3.5.6rc1, 3.6.5rc1 and 3.7.0 is vulnerable to catastrophic backtracking in pop3lib's apop() method. An attacker could use this flaw to cause denial of service.

    • Actualiza a 2.7.15-r0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →