p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ruby

Vulnerabilidades publicadas para ruby en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 37

  1. ALPINE-CVE-2023-28756

    Media · CVSS 5.3Corrección disponible

    ALPINE-CVE-2023-28756

    A ReDoS issue was discovered in the Time component through 0.2.1 in Ruby through 3.2.1. The Time parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to Time objects. The fixed versions are 0.1.1 and 0.2.2.

    • Actualiza a 3.0.6-r0
    Publicación Actualización
  2. ALPINE-CVE-2023-28755

    Media · CVSS 5.3Corrección disponible

    ALPINE-CVE-2023-28755

    A ReDoS issue was discovered in the URI component through 0.12.0 in Ruby through 3.2.1. The URI parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to URI objects. The fixed versions are 0.12.1, 0.11.1, 0.10.2 and 0.10.0.1.

    • Actualiza a 3.0.6-r0
    Publicación Actualización
  3. ALPINE-CVE-2021-33621

    Alta · CVSS 8.8Corrección disponible

    ALPINE-CVE-2021-33621

    The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object.

    • Actualiza a 3.0.5-r0
    Publicación Actualización
  4. ALPINE-CVE-2022-28739

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2022-28739

    There is a buffer over-read in Ruby before 2.6.10, 2.7.x before 2.7.6, 3.x before 3.0.4, and 3.1.x before 3.1.2. It occurs in String-to-Float conversion, including Kernel#Float and String#to_f.

    • Actualiza a 3.0.4-r0
    Publicación Actualización
  5. ALPINE-CVE-2022-28738

    Crítica · CVSS 9.8Corrección disponible

    ALPINE-CVE-2022-28738

    A double free was found in the Regexp compiler in Ruby 3.x before 3.0.4 and 3.1.x before 3.1.2. If a victim attempts to create a Regexp from untrusted user input, an attacker may be able to write to unexpected memory locations.

    • Actualiza a 3.0.4-r0
    Publicación Actualización
  6. ALPINE-CVE-2021-41816

    Crítica · CVSS 9.8Corrección disponible

    ALPINE-CVE-2021-41816

    CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on platforms (such as Windows) where size_t and long have different numbers of bytes. This also affects the CGI gem before 0.3.1 for Ruby.

    • Actualiza a 3.0.3-r0
    Publicación Actualización
  7. ALPINE-CVE-2021-32066

    Alta · CVSS 7.4Corrección disponible

    ALPINE-CVE-2021-32066

    An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. Net::IMAP does not raise an exception when StartTLS fails with an an unknown response, which might allow man-in-the-middle attackers to bypass the TLS protections by leveraging a network position between the client and the registry to block the StartTLS command, aka a "StartTLS stripping attack."

    • Actualiza a 2.7.4-r0
    Publicación Actualización
  8. ALPINE-CVE-2021-31810

    Media · CVSS 5.8Corrección disponible

    ALPINE-CVE-2021-31810

    An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. A malicious FTP server can use the PASV response to trick Net::FTP into connecting back to a given IP address and port. This potentially makes curl extract information about services that are otherwise private and not disclosed (e.g., the attacker can conduct port scans and service banner extractions).

    • Actualiza a 2.7.4-r0
    Publicación Actualización
  9. ALPINE-CVE-2021-28965

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2021-28965

    The REXML gem before 3.2.5 in Ruby before 2.6.7, 2.7.x before 2.7.3, and 3.x before 3.0.1 does not properly address XML round-trip issues. An incorrect document can be produced after parsing and serializing.

    • Actualiza a 2.7.3-r0
    Publicación Actualización
  10. ALPINE-CVE-2020-25613

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2020-25613

    An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.

    • Actualiza a 2.7.2-r0
    Publicación Actualización
  11. ALPINE-CVE-2020-10933

    Media · CVSS 5.3Corrección disponible

    ALPINE-CVE-2020-10933

    An issue was discovered in Ruby 2.5.x through 2.5.7, 2.6.x through 2.6.5, and 2.7.0. If a victim calls BasicSocket#read_nonblock(requested_size, buffer, exception: false), the method resizes the buffer to fit the requested size, but no data is copied. Thus, the buffer string provides the previous value of the heap. This may expose possibly sensitive data from the interpreter.

    • Actualiza a 2.6.6-r0
    Publicación Actualización
  12. ALPINE-CVE-2020-10663

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2020-10663

    The JSON gem through 2.2.0 for Ruby, as used in Ruby 2.4 through 2.4.9, 2.5 through 2.5.7, and 2.6 through 2.6.5, has an Unsafe Object Creation Vulnerability. This is quite similar to CVE-2013-0269, but does not rely on poor garbage-collection behavior within Ruby. Specifically, use of JSON parsing methods can lead to creation of a malicious object within the interpreter, with adverse effects that are application-dependent.

    • Actualiza a 2.6.6-r0
    Publicación Actualización
  13. ALPINE-CVE-2019-16255

    Alta · CVSS 8.1Corrección disponible

    ALPINE-CVE-2019-16255

    Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows code injection if the first argument (aka the "command" argument) to Shell#[] or Shell#test in lib/shell.rb is untrusted data. An attacker can exploit this to call an arbitrary Ruby method.

    • Actualiza a 2.6.5-r0
    Publicación Actualización
  14. ALPINE-CVE-2019-16254

    Media · CVSS 5.3Corrección disponible

    ALPINE-CVE-2019-16254

    Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows HTTP Response Splitting. If a program using WEBrick inserts untrusted input into the response header, an attacker can exploit it to insert a newline character to split a header, and inject malicious content to deceive clients. NOTE: this issue exists because of an incomplete fix for CVE-2017-17742, which addressed the CRLF vector, but did not address an isolated CR or an isolated LF.

    • Actualiza a 2.6.5-r0
    Publicación Actualización
  15. ALPINE-CVE-2019-16201

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2019-16201

    WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBrick server that uses DigestAuth to the Internet or a untrusted network.

    • Actualiza a 2.6.5-r0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →