p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de xz

Vulnerabilidades publicadas para xz en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 4

  1. ALPINE-CVE-2026-34743

    Media · CVSS 5.3Corrección disponible

    ALPINE-CVE-2026-34743

    XZ Utils provide a general-purpose data-compression library plus command-line tools. Prior to version 5.8.3, if lzma_index_decoder() was used to decode an Index that contained no Records, the resulting lzma_index was left in a state where where a subsequent lzma_index_append() would allocate too little memory, and a buffer overflow would occur. This issue has been patched in version 5.8.3.

    • Actualiza a 5.8.3-r0
    Publicación Actualización
  2. ALPINE-CVE-2025-31115

    Alta · CVSS 8.7Corrección disponible

    ALPINE-CVE-2025-31115

    XZ Utils provide a general-purpose data-compression library plus command-line tools. In XZ Utils 5.3.3alpha to 5.8.0, the multithreaded .xz decoder in liblzma has a bug where invalid input can at least result in a crash. The effects include heap use after free and writing to an address based on the null pointer plus an offset. Applications and libraries that use the lzma_stream_decoder_mt function are affected. The bug has been fixed in XZ Utils 5.8.1, and the fix has been committed to the v5.4, v5.6, v5.8, and master branches in the xz Git repository. No new release packages will be made from the old stable branches, but a standalone patch i

    • Actualiza a 5.6.2-r1
    Publicación Actualización
  3. ALPINE-CVE-2024-3094

    Crítica · CVSS 10Corrección disponible

    ALPINE-CVE-2024-3094

    Malicious code was discovered in the upstream tarballs of xz, starting with version 5.6.0. Through a series of complex obfuscations, the liblzma build process extracts a prebuilt object file from a disguised test file existing in the source code, which is then used to modify specific functions in the liblzma code. This results in a modified liblzma library that can be used by any software linked against this library, intercepting and modifying the data interaction with this library.

    • Actualiza a 5.6.1-r2
    Publicación Actualización
  4. ALPINE-CVE-2022-1271

    Alta · CVSS 8.8Corrección disponible

    ALPINE-CVE-2022-1271

    An arbitrary file write vulnerability was found in GNU gzip's zgrep utility. When zgrep is applied on the attacker's chosen file name (for example, a crafted file name), this can overwrite an attacker's content to an arbitrary attacker-selected file. This flaw occurs due to insufficient validation when processing filenames with two or more newlines where selected content and the target file names are embedded in crafted multi-line file names. This flaw allows a remote, low privileged attacker to force zgrep to write arbitrary files on the system.

    • Actualiza a 5.2.5-r1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →