p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de varnish

Vulnerabilidades publicadas para varnish en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 13

  1. ALPINE-CVE-2025-8671

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2025-8671

    A mismatch caused by client-triggered server-sent stream resets between HTTP/2 specifications and the internal architectures of some HTTP/2 implementations may result in excessive server resource consumption leading to denial-of-service (DoS). By opening streams and then rapidly triggering the server to reset them—using malformed frames or flow control errors—an attacker can exploit incorrect stream accounting. Streams reset by the server are considered closed at the protocol level, even though backend processing continues. This allows a client to cause the server to handle an unbounded number of concurrent streams on a single connection. Th

    • Actualiza a 7.7.2-r0
    Publicación Actualización
  2. ALPINE-CVE-2025-47905

    Media · CVSS 5.4Corrección disponible

    ALPINE-CVE-2025-47905

    Varnish Cache before 7.6.3 and 7.7 before 7.7.1, and Varnish Enterprise before 6.0.13r14, allow client-side desync via HTTP/1 requests, because the product incorrectly permits CRLF to be skipped to delimit chunk boundaries.

    • Actualiza a 7.7.1-r0
    Publicación Actualización
  3. ALPINE-CVE-2024-30156

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2024-30156

    Varnish Cache before 7.3.2 and 7.4.x before 7.4.3 (and before 6.0.13 LTS), and Varnish Enterprise 6 before 6.0.12r6, allows credits exhaustion for an HTTP/2 connection control flow window, aka a Broke Window Attack.

    • Actualiza a 7.5.0-r0
    Publicación Actualización
  4. ALPINE-CVE-2022-45060

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2022-45060

    An HTTP Request Forgery issue was discovered in Varnish Cache 5.x and 6.x before 6.0.11, 7.x before 7.1.2, and 7.2.x before 7.2.1. An attacker may introduce characters through HTTP/2 pseudo-headers that are invalid in the context of an HTTP/1 request line, causing the Varnish server to produce invalid HTTP/1 requests to the backend. This could, in turn, be used to exploit vulnerabilities in a server behind the Varnish server. Note: the 6.0.x LTS series (before 6.0.11) is affected.

    • Actualiza a 7.2.1-r0
    Publicación Actualización
  5. ALPINE-CVE-2022-45059

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2022-45059

    An issue was discovered in Varnish Cache 7.x before 7.1.2 and 7.2.x before 7.2.1. A request smuggling attack can be performed on Varnish Cache servers by requesting that certain headers are made hop-by-hop, preventing the Varnish Cache servers from forwarding critical headers to the backend.

    • Actualiza a 7.2.1-r0
    Publicación Actualización
  6. ALPINE-CVE-2022-38150

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2022-38150

    In Varnish Cache 7.0.0, 7.0.1, 7.0.2, and 7.1.0, it is possible to cause the Varnish Server to assert and automatically restart through forged HTTP/1 backend responses. An attack uses a crafted reason phrase of the backend response status line. This is fixed in 7.0.3 and 7.1.1.

    • Actualiza a 7.0.3-r0
    Publicación Actualización
  7. ALPINE-CVE-2022-23959

    Crítica · CVSS 9.1Corrección disponible

    ALPINE-CVE-2022-23959

    In Varnish Cache before 6.6.2 and 7.x before 7.0.2, Varnish Cache 6.0 LTS before 6.0.10, and and Varnish Enterprise (Cache Plus) 4.1.x before 4.1.11r6 and 6.0.x before 6.0.9r4, request smuggling can occur for HTTP/1 connections.

    • Actualiza a 7.0.2-r0
    Publicación Actualización
  8. ALPINE-CVE-2021-36740

    Media · CVSS 6.5Corrección disponible

    ALPINE-CVE-2021-36740

    Varnish Cache, with HTTP/2 enabled, allows request smuggling and VCL authorization bypass via a large Content-Length header for a POST request. This affects Varnish Enterprise 6.0.x before 6.0.8r3, and Varnish Cache 5.x and 6.x before 6.5.2, 6.6.x before 6.6.1, and 6.0 LTS before 6.0.8.

    • Actualiza a 6.6.1-r0
    Publicación Actualización
  9. ALPINE-CVE-2019-15892

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2019-15892

    An issue was discovered in Varnish Cache before 6.0.4 LTS, and 6.1.x and 6.2.x before 6.2.1. An HTTP/1 parsing failure allows a remote attacker to trigger an assert by sending crafted HTTP/1 requests. The assert will cause an automatic restart with a clean cache, which makes it a Denial of Service attack.

    • Actualiza a 6.2.1-r0
    Publicación Actualización
  10. ALPINE-CVE-2017-8807

    Crítica · CVSS 9.1Corrección disponible

    ALPINE-CVE-2017-8807

    vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects.

    • Actualiza a 5.2.1-r0
    Publicación Actualización
  11. ALPINE-CVE-2017-12425

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2017-12425

    An issue was discovered in Varnish HTTP Cache 4.0.1 through 4.0.4, 4.1.0 through 4.1.7, 5.0.0, and 5.1.0 through 5.1.2. A wrong if statement in the varnishd source code means that particular invalid requests from the client can trigger an assert, related to an Integer Overflow. This causes the varnishd worker process to abort and restart, losing the cached contents in the process. An attacker can therefore crash the varnishd worker process on demand and effectively keep it from serving content - a Denial-of-Service attack. The specific source-code filename containing the incorrect statement varies across releases.

    • Actualiza a 5.1.3-r0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →