ALSA-2022:7821
ALSA-2022:7821 · Important: nodejs:18 security update
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. The following packages have been upgraded to a later upstream version: nodejs (18.9.1). (BZ#2130559, BZ#2131750) Security Fix(es): * nodejs: weak randomness in WebCrypto keygen (CVE-2022-35255) * nodejs: HTTP Request Smuggling due to incorrect parsing of header fields (CVE-2022-35256) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
nodejs AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:18.9.1-1.module_el8.7.0+3343+ea2b7901
Actualiza a 1:18.9.1-1.module_el8.7.0+3343+ea2b7901
nodejs-devel AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:18.9.1-1.module_el8.7.0+3343+ea2b7901
Actualiza a 1:18.9.1-1.module_el8.7.0+3343+ea2b7901
nodejs-docs AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:18.9.1-1.module_el8.7.0+3343+ea2b7901
Actualiza a 1:18.9.1-1.module_el8.7.0+3343+ea2b7901
nodejs-full-i18n AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:18.9.1-1.module_el8.7.0+3343+ea2b7901
Actualiza a 1:18.9.1-1.module_el8.7.0+3343+ea2b7901
nodejs-nodemon AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.0.19-1.module_el8.7.0+3343+ea2b7901
Actualiza a 2.0.19-1.module_el8.7.0+3343+ea2b7901
nodejs-packaging AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 2021.06-4.module_el8.7.0+3343+ea2b7901
Actualiza a 2021.06-4.module_el8.7.0+3343+ea2b7901
nodejs-packaging-bundler AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 2021.06-4.module_el8.7.0+3343+ea2b7901
Actualiza a 2021.06-4.module_el8.7.0+3343+ea2b7901
npm AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:8.19.1-1.18.9.1.1.module_el8.7.0+3343+ea2b7901
Actualiza a 1:8.19.1-1.18.9.1.1.module_el8.7.0+3343+ea2b7901
Fuentes originales
- https://access.redhat.com/errata/RHSA-2022:7821
- https://access.redhat.com/security/cve/CVE-2022-35255
- https://access.redhat.com/security/cve/CVE-2022-35256
- https://bugzilla.redhat.com/2130517
- https://bugzilla.redhat.com/2130518
- https://errata.almalinux.org/8/ALSA-2022-7821.html
- https://osv.dev/vulnerability/ALSA-2022:7821