ALSA-2022:9073
ALSA-2022:9073 · Moderate: nodejs:16 security, bug fix, and enhancement update
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. The following packages were updated to later upstream versions: nodejs (16.18.1), nodejs-nodemon (2.0.20). Security Fix(es): * nodejs: Improper handling of URI Subject Alternative Names (CVE-2021-44531) * nodejs: Certificate Verification Bypass via String Injection (CVE-2021-44532) * nodejs: Incorrect handling of certificate subject and issuer fields (CVE-2021-44533) * minimist: prototype pollution (CVE-2021-44906) * nodejs-minimatch: ReDoS via the braceExpand function (CVE-2022-3517) * nodejs: DNS rebinding in inspect via invalid octal IP address (CVE-2022-43548) * nodejs: Prototype pollution via console.table properties (CVE-2022-21824) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Bug Fix(es): * nodejs:16/nodejs: Packaged version of undici does not fit with declared version. [almalinux-8] (BZ#2151625)
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
nodejs AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:16.18.1-3.module_el8.7.0+3371+ed8c43db
Actualiza a 1:16.18.1-3.module_el8.7.0+3371+ed8c43db
nodejs-devel AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:16.18.1-3.module_el8.7.0+3371+ed8c43db
Actualiza a 1:16.18.1-3.module_el8.7.0+3371+ed8c43db
nodejs-docs AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:16.18.1-3.module_el8.7.0+3371+ed8c43db
Actualiza a 1:16.18.1-3.module_el8.7.0+3371+ed8c43db
nodejs-full-i18n AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:16.18.1-3.module_el8.7.0+3371+ed8c43db
Actualiza a 1:16.18.1-3.module_el8.7.0+3371+ed8c43db
nodejs-nodemon AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.0.20-2.module_el8.7.0+3371+ed8c43db
Actualiza a 2.0.20-2.module_el8.7.0+3371+ed8c43db
nodejs-packaging AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 25-1.module_el8.5.0+2605+45d748af
Actualiza a 25-1.module_el8.5.0+2605+45d748af
npm AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:8.19.2-1.16.18.1.3.module_el8.7.0+3371+ed8c43db
Actualiza a 1:8.19.2-1.16.18.1.3.module_el8.7.0+3371+ed8c43db
Fuentes originales
- https://access.redhat.com/errata/RHSA-2022:9073
- https://access.redhat.com/security/cve/CVE-2021-44531
- https://access.redhat.com/security/cve/CVE-2021-44532
- https://access.redhat.com/security/cve/CVE-2021-44533
- https://access.redhat.com/security/cve/CVE-2021-44906
- https://access.redhat.com/security/cve/CVE-2022-21824
- https://access.redhat.com/security/cve/CVE-2022-3517
- https://access.redhat.com/security/cve/CVE-2022-43548
- https://bugzilla.redhat.com/2040839
- https://bugzilla.redhat.com/2040846
- https://bugzilla.redhat.com/2040856
- https://bugzilla.redhat.com/2040862
- https://bugzilla.redhat.com/2066009
- https://bugzilla.redhat.com/2134609
- https://bugzilla.redhat.com/2140911
- https://errata.almalinux.org/8/ALSA-2022-9073.html
- https://osv.dev/vulnerability/ALSA-2022:9073