ALSA-2023:4536
ALSA-2023:4536 · Moderate: nodejs:18 security, bug fix, and enhancement update
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. The package has been upgraded to a later upstream version: nodejs (18.16.1). (BZ#2223630, BZ#2223631, BZ#2223632, BZ#2223633, BZ#2223635, BZ#2223642) Security Fix(es): * nodejs: mainModule.proto bypass experimental policy mechanism (CVE-2023-30581) * nodejs: process interuption due to invalid Public Key information in x509 certificates (CVE-2023-30588) * nodejs: HTTP Request Smuggling via Empty headers separated by CR (CVE-2023-30589) * nodejs: DiffieHellman do not generate keys after setting a private key (CVE-2023-30590) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Bug Fix(es): * nodejs:18/nodejs: Don't assume FIPS is disabled by default [almalinux-8] (BZ#2223639)
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
nodejs AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:18.16.1-1.module_el8.8.0+3595+0818e803
Actualiza a 1:18.16.1-1.module_el8.8.0+3595+0818e803
nodejs-devel AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:18.16.1-1.module_el8.8.0+3595+0818e803
Actualiza a 1:18.16.1-1.module_el8.8.0+3595+0818e803
nodejs-docs AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:18.16.1-1.module_el8.8.0+3595+0818e803
Actualiza a 1:18.16.1-1.module_el8.8.0+3595+0818e803
nodejs-full-i18n AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:18.16.1-1.module_el8.8.0+3595+0818e803
Actualiza a 1:18.16.1-1.module_el8.8.0+3595+0818e803
nodejs-nodemon AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.0.20-2.module_el8.8.0+3587+ee652244
Actualiza a 2.0.20-2.module_el8.8.0+3587+ee652244
nodejs-packaging AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 2021.06-4.module_el8.7.0+3343+ea2b7901
Actualiza a 2021.06-4.module_el8.7.0+3343+ea2b7901
nodejs-packaging-bundler AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 2021.06-4.module_el8.7.0+3343+ea2b7901
Actualiza a 2021.06-4.module_el8.7.0+3343+ea2b7901
npm AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:9.5.1-1.18.16.1.1.module_el8.8.0+3595+0818e803
Actualiza a 1:9.5.1-1.18.16.1.1.module_el8.8.0+3595+0818e803
Fuentes originales
- https://access.redhat.com/errata/RHSA-2023:4536
- https://access.redhat.com/security/cve/CVE-2023-30581
- https://access.redhat.com/security/cve/CVE-2023-30588
- https://access.redhat.com/security/cve/CVE-2023-30589
- https://access.redhat.com/security/cve/CVE-2023-30590
- https://bugzilla.redhat.com/2219824
- https://bugzilla.redhat.com/2219838
- https://bugzilla.redhat.com/2219841
- https://bugzilla.redhat.com/2219842
- https://errata.almalinux.org/8/ALSA-2023-4536.html
- https://osv.dev/vulnerability/ALSA-2023:4536