ALSA-2023:4537
ALSA-2023:4537 · Moderate: nodejs:16 security, bug fix, and enhancement update
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. The package has been upgraded to a later upstream version: nodejs (16.20.1). (BZ#2223678, BZ#2223680, BZ#2223682, BZ#2223684, BZ#2223686, BZ#2223688) Security Fix(es): * nodejs: mainModule.proto bypass experimental policy mechanism (CVE-2023-30581) * nodejs: process interuption due to invalid Public Key information in x509 certificates (CVE-2023-30588) * nodejs: HTTP Request Smuggling via Empty headers separated by CR (CVE-2023-30589) * nodejs: DiffieHellman do not generate keys after setting a private key (CVE-2023-30590) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
nodejs AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:16.20.1-1.module_el8.8.0+3594+e74fe53f
Actualiza a 1:16.20.1-1.module_el8.8.0+3594+e74fe53f
nodejs-devel AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:16.20.1-1.module_el8.8.0+3594+e74fe53f
Actualiza a 1:16.20.1-1.module_el8.8.0+3594+e74fe53f
nodejs-docs AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:16.20.1-1.module_el8.8.0+3594+e74fe53f
Actualiza a 1:16.20.1-1.module_el8.8.0+3594+e74fe53f
nodejs-full-i18n AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:16.20.1-1.module_el8.8.0+3594+e74fe53f
Actualiza a 1:16.20.1-1.module_el8.8.0+3594+e74fe53f
nodejs-nodemon AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.0.20-3.module_el8.8.0+3586+d4fc0b72
Actualiza a 2.0.20-3.module_el8.8.0+3586+d4fc0b72
nodejs-packaging AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 25-1.module_el8.5.0+2605+45d748af
Actualiza a 25-1.module_el8.5.0+2605+45d748af
npm AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:8.19.4-1.16.20.1.1.module_el8.8.0+3594+e74fe53f
Actualiza a 1:8.19.4-1.16.20.1.1.module_el8.8.0+3594+e74fe53f
Fuentes originales
- https://access.redhat.com/errata/RHSA-2023:4537
- https://access.redhat.com/security/cve/CVE-2023-30581
- https://access.redhat.com/security/cve/CVE-2023-30588
- https://access.redhat.com/security/cve/CVE-2023-30589
- https://access.redhat.com/security/cve/CVE-2023-30590
- https://bugzilla.redhat.com/2219824
- https://bugzilla.redhat.com/2219838
- https://bugzilla.redhat.com/2219841
- https://bugzilla.redhat.com/2219842
- https://errata.almalinux.org/8/ALSA-2023-4537.html
- https://osv.dev/vulnerability/ALSA-2023:4537