ALSA-2023:7257
ALSA-2023:7257 · Moderate: dotnet6.0 security update
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
.NET is a managed-software framework. It implements a subset of the .NET framework APIs and several new APIs, and it includes a CLR implementation. New versions of .NET that address a security vulnerability are now available. The updated versions are .NET SDK 6.0.125 and .NET Runtime 6.0.25. Security Fix(es): * dotnet: Arbitrary File Write and Deletion Vulnerability: FormatFtpCommand (CVE-2023-36049) * dotnet: ASP.NET Security Feature Bypass Vulnerability in Blazor forms (CVE-2023-36558) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
aspnetcore-runtime-6.0 AlmaLinux:9
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.25-1.el9_3
Actualiza a 6.0.25-1.el9_3
aspnetcore-targeting-pack-6.0 AlmaLinux:9
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.25-1.el9_3
Actualiza a 6.0.25-1.el9_3
dotnet-apphost-pack-6.0 AlmaLinux:9
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.25-1.el9_3
Actualiza a 6.0.25-1.el9_3
dotnet-hostfxr-6.0 AlmaLinux:9
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.25-1.el9_3
Actualiza a 6.0.25-1.el9_3
dotnet-runtime-6.0 AlmaLinux:9
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.25-1.el9_3
Actualiza a 6.0.25-1.el9_3
dotnet-sdk-6.0 AlmaLinux:9
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.125-1.el9_3
Actualiza a 6.0.125-1.el9_3
dotnet-sdk-6.0-source-built-artifacts AlmaLinux:9
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.125-1.el9_3
Actualiza a 6.0.125-1.el9_3
dotnet-targeting-pack-6.0 AlmaLinux:9
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.25-1.el9_3
Actualiza a 6.0.25-1.el9_3
dotnet-templates-6.0 AlmaLinux:9
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.125-1.el9_3
Actualiza a 6.0.125-1.el9_3
Fuentes originales
- https://access.redhat.com/errata/RHSA-2023:7257
- https://access.redhat.com/security/cve/CVE-2023-36049
- https://access.redhat.com/security/cve/CVE-2023-36558
- https://bugzilla.redhat.com/2247750
- https://bugzilla.redhat.com/2248883
- https://errata.almalinux.org/9/ALSA-2023-7257.html
- https://osv.dev/vulnerability/ALSA-2023:7257