ALSA-2024:0808
ALSA-2024:0808 · Important: dotnet6.0 security update
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
.NET is a managed-software framework. It implements a subset of the .NET framework APIs and several new APIs, and it includes a CLR implementation. New versions of .NET that address a security vulnerability are now available. The updated versions are .NET SDK 6.0.127 and .NET Runtime 6.0.27. Security Fix(es): * dotnet: Denial of Service in SignalR server (CVE-2024-21386) * dotnet: Denial of Service in X509Certificate2 (CVE-2024-21404) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
aspnetcore-runtime-6.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.27-1.el8_9
Actualiza a 6.0.27-1.el8_9
aspnetcore-targeting-pack-6.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.27-1.el8_9
Actualiza a 6.0.27-1.el8_9
dotnet-apphost-pack-6.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.27-1.el8_9
Actualiza a 6.0.27-1.el8_9
dotnet-hostfxr-6.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.27-1.el8_9
Actualiza a 6.0.27-1.el8_9
dotnet-runtime-6.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.27-1.el8_9
Actualiza a 6.0.27-1.el8_9
dotnet-sdk-6.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.127-1.el8_9
Actualiza a 6.0.127-1.el8_9
dotnet-sdk-6.0-source-built-artifacts AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.127-1.el8_9
Actualiza a 6.0.127-1.el8_9
dotnet-targeting-pack-6.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.27-1.el8_9
Actualiza a 6.0.27-1.el8_9
dotnet-templates-6.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.127-1.el8_9
Actualiza a 6.0.127-1.el8_9
Fuentes originales
- https://access.redhat.com/errata/RHSA-2024:0808
- https://access.redhat.com/security/cve/CVE-2024-21386
- https://access.redhat.com/security/cve/CVE-2024-21404
- https://bugzilla.redhat.com/2263085
- https://bugzilla.redhat.com/2263086
- https://errata.almalinux.org/8/ALSA-2024-0808.html
- https://osv.dev/vulnerability/ALSA-2024:0808