ALSA-2024:3340
ALSA-2024:3340 · Important: .NET 7.0 security update
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
.NET is a managed-software framework. It implements a subset of the .NET framework APIs and several new APIs, and it includes a CLR implementation. New versions of .NET that address a security vulnerability are now available. The updated versions are .NET SDK 7.0.119 and .NET Runtime 7.0.19. Security Fix(es): * dotnet: stack buffer overrun in Double Parse (CVE-2024-30045) * dotnet: denial of service in ASP.NET Core due to deadlock in Http2OutputProducer.Stop() (CVE-2024-30046) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
aspnetcore-runtime-7.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.0.19-1.el8_10
Actualiza a 7.0.19-1.el8_10
aspnetcore-targeting-pack-7.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.0.19-1.el8_10
Actualiza a 7.0.19-1.el8_10
dotnet-apphost-pack-7.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.0.19-1.el8_10
Actualiza a 7.0.19-1.el8_10
dotnet-hostfxr-7.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.0.19-1.el8_10
Actualiza a 7.0.19-1.el8_10
dotnet-runtime-7.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.0.19-1.el8_10
Actualiza a 7.0.19-1.el8_10
dotnet-sdk-7.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.0.119-1.el8_10
Actualiza a 7.0.119-1.el8_10
dotnet-sdk-7.0-source-built-artifacts AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.0.119-1.el8_10
Actualiza a 7.0.119-1.el8_10
dotnet-targeting-pack-7.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.0.19-1.el8_10
Actualiza a 7.0.19-1.el8_10
dotnet-templates-7.0 AlmaLinux:8
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.0.119-1.el8_10
Actualiza a 7.0.119-1.el8_10
Fuentes originales
- https://access.redhat.com/errata/RHSA-2024:3340
- https://access.redhat.com/security/cve/CVE-2024-30045
- https://access.redhat.com/security/cve/CVE-2024-30046
- https://bugzilla.redhat.com/2279695
- https://bugzilla.redhat.com/2279697
- https://errata.almalinux.org/8/ALSA-2024-3340.html
- https://osv.dev/vulnerability/ALSA-2024:3340