CVE-2017-20162
CVE-2017-20162 · vercel ms index.js parse redos
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A vulnerability, which was classified as problematic, has been found in vercel ms up to 1.x. This issue affects the function parse of the file index.js. The manipulation of the argument str leads to inefficient regular expression complexity. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named caae2988ba2a37765d055c4eee63d383320ee662. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217451.
CVSS 4.3 · Media · EPSS 1,0% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
ms
- Versiones
- 1.x: Afectada
Sin corrección publicada
ms npm
- Intervalos de versiones afectados
- SEMVER: < 2.0.0
Actualiza a 2.0.0
npm Ubuntu:14.04:LTS
- Versiones
- 1.2.18~dfsg-3
- 1.3.10~dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
npm Ubuntu:Pro:16.04:LTS
- Versiones
- 1.4.21+ds-2
- 3.5.2-0ubuntu4
- 3.5.2-0ubuntu4.1.16.04.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
npm Ubuntu:Pro:18.04:LTS
- Versiones
- 3.5.2-0ubuntu4
- 3.5.2-0ubuntu4.1.18.04.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
npm Ubuntu:20.04:LTS
- Versiones
- 5.8.0+ds6-4
- 6.14.4+ds-1ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
npm Ubuntu:22.04:LTS
- Versiones
- 7.5.2+ds-2
- 7.24.2+ds-1
- 7.24.2+ds-2
- 8.3.0~ds-1
- 8.3.0~ds-2
- 8.3.2~ds-1
- 8.5.0~ds-1
- 8.5.1~ds-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
qt6-webengine Ubuntu:22.04:LTS
- Versiones
- 6.2.2+dfsg-6ubuntu2
- 6.2.4+dfsg-1ubuntu1
- 6.2.4+dfsg-1ubuntu2
- 6.2.4+dfsg-6ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
npm Ubuntu:24.04:LTS
- Versiones
- 9.2.0~ds1-1
- 9.2.0~ds1-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
qt6-webengine Ubuntu:24.04:LTS
- Versiones
- 6.4.2-final+dfsg-11
- 6.4.2-final+dfsg-12
- 6.4.2-final+dfsg-12build1
- 6.4.2-final+dfsg-12ubuntu1
- 6.4.2-final+dfsg-12ubuntu7
- 6.4.2-final+dfsg-12ubuntu9
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
npm Ubuntu:25.10
- Versiones
- 9.2.0~ds1-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
qt6-webengine Ubuntu:25.10
- Versiones
- 6.8.3+dfsg-0ubuntu1
- 6.8.3+dfsg-0ubuntu2
- 6.9.2+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
npm Ubuntu:26.10
- Versiones
- 9.2.0~ds3-1
- 11.16.0+ds2-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
qt6-webengine Ubuntu:26.10
- Versiones
- 6.10.2+dfsg-1
- 6.10.2+dfsg-4
- 6.10.2+dfsg-5
- 6.11.2+dfsg-3ubuntu1
- 6.11.2+dfsg-3ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
npm Ubuntu:26.04:LTS
- Versiones
- 9.2.0~ds1-3
- 9.2.0~ds2-2
- 9.2.0~ds3-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
qt6-webengine Ubuntu:26.04:LTS
- Versiones
- 6.9.2+dfsg-2
- 6.9.2+dfsg-4
- 6.9.2+dfsg-4build1
- 6.9.2+dfsg-4build2
- 6.10.2+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://vuldb.com/?id.217451
- https://vuldb.com/?ctiid.217451
- https://github.com/vercel/ms/pull/89
- https://github.com/vercel/ms/commit/caae2988ba2a37765d055c4eee63d383320ee662
- https://github.com/vercel/ms/releases/tag/2.0.0
- https://security.netapp.com/advisory/ntap-20241108-0002/
- https://nvd.nist.gov/vuln/detail/CVE-2017-20162