p PatchFirst

CVE-2017-7869

CVE-2017-7869

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

GnuTLS before 2017-02-20 has an out-of-bounds write caused by an integer overflow and heap-based buffer overflow related to the cdk_pkt_read function in opencdk/read-packet.c. This issue (which is a subset of the vendor's GNUTLS-SA-2017-3 report) is fixed in 3.5.10.

CVSS 7.5 · Alta · EPSS 2,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • n/a

    Versiones
    • n/a: Afectada

    Sin corrección publicada

  • gnutls28 Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.5.8-4

    Actualiza a 3.5.8-4

  • gnutls28 Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.5.8-4

    Actualiza a 3.5.8-4

  • gnutls28 Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.5.8-4

    Actualiza a 3.5.8-4

  • gnutls26 Ubuntu:14.04:LTS

    Versiones
    • 2.12.23-1ubuntu4
    • 2.12.23-1ubuntu5
    • 2.12.23-12ubuntu1
    • 2.12.23-12ubuntu2
    • 2.12.23-12ubuntu2.1
    • 2.12.23-12ubuntu2.2
    • 2.12.23-12ubuntu2.3
    • 2.12.23-12ubuntu2.4
    • 2.12.23-12ubuntu2.5
    • 2.12.23-12ubuntu2.6
    • 2.12.23-12ubuntu2.7
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.12.23-12ubuntu2.8

    Actualiza a 2.12.23-12ubuntu2.8

  • gnutls28 Ubuntu:16.04:LTS

    Versiones
    • 3.3.15-5ubuntu2
    • 3.3.18-1ubuntu1
    • 3.3.20-1ubuntu1
    • 3.4.9-2ubuntu1
    • 3.4.10-4ubuntu1
    • 3.4.10-4ubuntu1.1
    • 3.4.10-4ubuntu1.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.4.10-4ubuntu1.3

    Actualiza a 3.4.10-4ubuntu1.3

Fuentes originales

Comprueba tu servidor →