p PatchFirst

CVE-2018-0739

CVE-2018-0739 · Constructed ASN.1 types with a recursive definition could exceed the stack

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.

Constructed ASN.1 types with a recursive definition (such as can be found in PKCS7) could eventually exceed the stack given malicious input with excessive recursion. This could result in a Denial Of Service attack. There are no such structures used within SSL/TLS that come from untrusted sources so this is considered safe. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g). Fixed in OpenSSL 1.0.2o (Affected 1.0.2b-1.0.2n).

CVSS 6.5 · Media · EPSS 18,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · network

Productos y versiones afectados

  • openssl

    Versiones
    • Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g): Afectada
    • Fixed in OpenSSL 1.0.2o (Affected 1.0.2b-1.0.2n): Afectada

    Sin corrección publicada

  • libtomcrypt Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.18.2-1

    Actualiza a 1.18.2-1

  • libtomcrypt Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.18.2-1

    Actualiza a 1.18.2-1

  • libtomcrypt Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.18.2-1

    Actualiza a 1.18.2-1

  • openssl Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.1.0h-1

    Actualiza a 1.1.0h-1

  • openssl Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.1.0h-1

    Actualiza a 1.1.0h-1

  • openssl Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.1.0h-1

    Actualiza a 1.1.0h-1

  • openssl Ubuntu:14.04:LTS

    Versiones
    • 1.0.1e-3ubuntu1
    • 1.0.1e-4ubuntu1
    • 1.0.1e-4ubuntu2
    • 1.0.1e-4ubuntu3
    • 1.0.1e-4ubuntu4
    • 1.0.1f-1ubuntu1
    • 1.0.1f-1ubuntu2
    • 1.0.1f-1ubuntu2.1
    • 1.0.1f-1ubuntu2.2
    • 1.0.1f-1ubuntu2.3
    • 1.0.1f-1ubuntu2.4
    • 1.0.1f-1ubuntu2.5
    • 1.0.1f-1ubuntu2.7
    • 1.0.1f-1ubuntu2.8
    • 1.0.1f-1ubuntu2.11
    • 1.0.1f-1ubuntu2.12
    • 1.0.1f-1ubuntu2.15
    • 1.0.1f-1ubuntu2.16
    • 1.0.1f-1ubuntu2.17
    • 1.0.1f-1ubuntu2.18
    • 1.0.1f-1ubuntu2.19
    • 1.0.1f-1ubuntu2.20
    • 1.0.1f-1ubuntu2.21
    • 1.0.1f-1ubuntu2.22
    • 1.0.1f-1ubuntu2.23
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.0.1f-1ubuntu2.24

    Actualiza a 1.0.1f-1ubuntu2.24

  • openssl Ubuntu:16.04:LTS

    Versiones
    • 1.0.2d-0ubuntu1
    • 1.0.2d-0ubuntu2
    • 1.0.2e-1ubuntu1
    • 1.0.2f-2ubuntu1
    • 1.0.2g-1ubuntu2
    • 1.0.2g-1ubuntu3
    • 1.0.2g-1ubuntu4
    • 1.0.2g-1ubuntu4.1
    • 1.0.2g-1ubuntu4.2
    • 1.0.2g-1ubuntu4.4
    • 1.0.2g-1ubuntu4.5
    • 1.0.2g-1ubuntu4.6
    • 1.0.2g-1ubuntu4.8
    • 1.0.2g-1ubuntu4.9
    • 1.0.2g-1ubuntu4.10
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.0.2g-1ubuntu4.11

    Actualiza a 1.0.2g-1ubuntu4.11

  • openssl Ubuntu:18.04:LTS

    Versiones
    • 1.0.2g-1ubuntu13
    • 1.0.2g-1ubuntu14
    • 1.0.2n-1ubuntu1
    • 1.1.0g-2ubuntu1
    • 1.1.0g-2ubuntu2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.1.0g-2ubuntu3

    Actualiza a 1.1.0g-2ubuntu3

  • openssl1.0 Ubuntu:18.04:LTS

    Versiones
    • 1.0.2n-1ubuntu2
    • 1.0.2n-1ubuntu3
    • 1.0.2n-1ubuntu4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.0.2n-1ubuntu5

    Actualiza a 1.0.2n-1ubuntu5

Fuentes originales

Comprueba tu servidor →