p PatchFirst

CVE-2018-1000074

CVE-2018-1000074

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.

CVSS 7.8 · Alta · EPSS 2,9% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • n/a

    Versiones
    • n/a: Afectada

    Sin corrección publicada

  • jruby Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.1.17.0-1

    Actualiza a 9.1.17.0-1

  • jruby Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.1.17.0-1

    Actualiza a 9.1.17.0-1

  • jruby Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.1.17.0-1

    Actualiza a 9.1.17.0-1

  • rubygems Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Actualiza a 3.2.0~rc.1-1

  • rubygems Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Actualiza a 3.2.0~rc.1-1

  • rubygems Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Actualiza a 3.2.0~rc.1-1

  • ruby1.9.1 Ubuntu:14.04:LTS

    Versiones
    • 1.9.3.194-8.1ubuntu2
    • 1.9.3.448-1ubuntu1
    • 1.9.3.448-1ubuntu2
    • 1.9.3.484-1ubuntu1
    • 1.9.3.484-1ubuntu2
    • 1.9.3.484-2ubuntu1
    • 1.9.3.484-2ubuntu1.1
    • 1.9.3.484-2ubuntu1.2
    • 1.9.3.484-2ubuntu1.3
    • 1.9.3.484-2ubuntu1.5
    • 1.9.3.484-2ubuntu1.6
    • 1.9.3.484-2ubuntu1.7
    • 1.9.3.484-2ubuntu1.8
    • 1.9.3.484-2ubuntu1.10
    • 1.9.3.484-2ubuntu1.11
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.9.3.484-2ubuntu1.12

    Actualiza a 1.9.3.484-2ubuntu1.12

  • ruby2.0 Ubuntu:14.04:LTS

    Versiones
    • 2.0.0.299-2
    • 2.0.0.343-1
    • 2.0.0.343-1ubuntu1
    • 2.0.0.353-1
    • 2.0.0.353-1ubuntu1
    • 2.0.0.484-1ubuntu1
    • 2.0.0.484-1ubuntu2
    • 2.0.0.484-1ubuntu2.1
    • 2.0.0.484-1ubuntu2.2
    • 2.0.0.484-1ubuntu2.4
    • 2.0.0.484-1ubuntu2.5
    • 2.0.0.484-1ubuntu2.6
    • 2.0.0.484-1ubuntu2.8
    • 2.0.0.484-1ubuntu2.9
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.0.0.484-1ubuntu2.10

    Actualiza a 2.0.0.484-1ubuntu2.10

  • jruby Ubuntu:Pro:14.04:LTS

    Versiones
    • 1.5.6-5ubuntu1
    • 1.5.6-6
    • 1.5.6-7
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.6-9+deb8u2build0.14.04.1~esm2

    Actualiza a 1.5.6-9+deb8u2build0.14.04.1~esm2

  • ruby2.3 Ubuntu:16.04:LTS

    Versiones
    • 2.3.0-1
    • 2.3.0-2
    • 2.3.0-4ubuntu2
    • 2.3.0-4ubuntu3
    • 2.3.0-5ubuntu1
    • 2.3.1-2~16.04
    • 2.3.1-2~16.04.2
    • 2.3.1-2~16.04.4
    • 2.3.1-2~16.04.5
    • 2.3.1-2~16.04.6
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.3.1-2~16.04.7

    Actualiza a 2.3.1-2~16.04.7

  • jruby Ubuntu:16.04:LTS

    Versiones
    • 1.7.21-2ubuntu4
    • 1.7.22-1ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jruby Ubuntu:18.04:LTS

    Versiones
    • 9.1.13.0-1
    • 9.1.17.0-1~18.04
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →