CVE-2018-1000076
CVE-2018-1000076
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Verification of Cryptographic Signature vulnerability in package.rb that can result in a mis-signed gem could be installed, as the tarball would contain multiple gem signatures.. This vulnerability appears to have been fixed in 2.7.6.
CVSS 9.8 · Crítica · EPSS 2,9% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
n/a
- Versiones
- n/a: Afectada
Sin corrección publicada
jruby Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.1.17.0-1
Actualiza a 9.1.17.0-1
jruby Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.1.17.0-1
Actualiza a 9.1.17.0-1
jruby Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.1.17.0-1
Actualiza a 9.1.17.0-1
rubygems Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.2.0~rc.1-1
Actualiza a 3.2.0~rc.1-1
rubygems Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.2.0~rc.1-1
Actualiza a 3.2.0~rc.1-1
rubygems Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.2.0~rc.1-1
Actualiza a 3.2.0~rc.1-1
ruby2.0 Ubuntu:14.04:LTS
- Versiones
- 2.0.0.299-2
- 2.0.0.343-1
- 2.0.0.343-1ubuntu1
- 2.0.0.353-1
- 2.0.0.353-1ubuntu1
- 2.0.0.484-1ubuntu1
- 2.0.0.484-1ubuntu2
- 2.0.0.484-1ubuntu2.1
- 2.0.0.484-1ubuntu2.2
- 2.0.0.484-1ubuntu2.4
- 2.0.0.484-1ubuntu2.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.0.0.484-1ubuntu2.6
Actualiza a 2.0.0.484-1ubuntu2.6
jruby Ubuntu:Pro:14.04:LTS
- Versiones
- 1.5.6-5ubuntu1
- 1.5.6-6
- 1.5.6-7
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.5.6-9+deb8u2build0.14.04.1~esm2
Actualiza a 1.5.6-9+deb8u2build0.14.04.1~esm2
ruby2.3 Ubuntu:16.04:LTS
- Versiones
- 2.3.0-1
- 2.3.0-2
- 2.3.0-4ubuntu2
- 2.3.0-4ubuntu3
- 2.3.0-5ubuntu1
- 2.3.1-2~16.04
- 2.3.1-2~16.04.2
- 2.3.1-2~16.04.4
- 2.3.1-2~16.04.5
- 2.3.1-2~16.04.6
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.3.1-2~16.04.7
Actualiza a 2.3.1-2~16.04.7
jruby Ubuntu:16.04:LTS
- Versiones
- 1.7.21-2ubuntu4
- 1.7.22-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
jruby Ubuntu:18.04:LTS
- Versiones
- 9.1.13.0-1
- 9.1.17.0-1~18.04
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://www.debian.org/security/2018/dsa-4219
- https://usn.ubuntu.com/3621-1/
- https://access.redhat.com/errata/RHSA-2018:3729
- https://access.redhat.com/errata/RHSA-2018:3730
- https://lists.debian.org/debian-lts-announce/2018/04/msg00023.html
- https://access.redhat.com/errata/RHSA-2018:3731
- https://lists.debian.org/debian-lts-announce/2018/04/msg00001.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- https://www.debian.org/security/2018/dsa-4259
- http://blog.rubygems.org/2018/02/15/2.7.6-released.html
- https://github.com/rubygems/rubygems/commit/f5042b879259b1f1ce95a0c5082622c646376693
- https://lists.debian.org/debian-lts-announce/2018/04/msg00000.html
- https://lists.debian.org/debian-lts-announce/2019/05/msg00028.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
- https://access.redhat.com/errata/RHSA-2019:2028
- https://access.redhat.com/errata/RHSA-2020:0542
- https://access.redhat.com/errata/RHSA-2020:0591
- https://access.redhat.com/errata/RHSA-2020:0663
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000076