p PatchFirst

CVE-2019-1547

CVE-2019-1547 · ECDSA remote timing attack

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.

Normally in OpenSSL EC groups always have a co-factor present and this is used in side channel resistant code paths. However, in some cases, it is possible to construct a group using explicit parameters (instead of using a named curve). In those cases it is possible that such a group does not have the cofactor present. This can occur even where all the parameters match a known named curve. If such a curve is used then OpenSSL falls back to non-side channel resistant code paths which may result in full key recovery during an ECDSA signature operation. In order to be vulnerable an attacker would have to have the ability to time the creation of a large number of signatures where explicit parameters with no co-factor present are in use by an application using libcrypto. For the avoidance of doubt libssl is not vulnerable because explicit parameters are never used. Fixed in OpenSSL 1.1.1d (Affected 1.1.1-1.1.1c). Fixed in OpenSSL 1.1.0l (Affected 1.1.0-1.1.0k). Fixed in OpenSSL 1.0.2t (Affected 1.0.2-1.0.2s).

CVSS 4.7 · Media · EPSS 1,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · network

Productos y versiones afectados

  • openssl

    Versiones
    • Fixed in OpenSSL 1.1.1d (Affected 1.1.1-1.1.1c): Afectada
    • Fixed in OpenSSL 1.1.0l (Affected 1.1.0-1.1.0k): Afectada
    • Fixed in OpenSSL 1.0.2t (Affected 1.0.2-1.0.2s): Afectada

    Sin corrección publicada

  • openssl Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.1.1d-1

    Actualiza a 1.1.1d-1

  • openssl Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.1.1d-1

    Actualiza a 1.1.1d-1

  • openssl Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.1.1d-1

    Actualiza a 1.1.1d-1

  • openssl Ubuntu:Pro:14.04:LTS

    Versiones
    • 1.0.1e-3ubuntu1
    • 1.0.1e-4ubuntu1
    • 1.0.1e-4ubuntu2
    • 1.0.1e-4ubuntu3
    • 1.0.1e-4ubuntu4
    • 1.0.1f-1ubuntu1
    • 1.0.1f-1ubuntu2
    • 1.0.1f-1ubuntu2.1
    • 1.0.1f-1ubuntu2.2
    • 1.0.1f-1ubuntu2.3
    • 1.0.1f-1ubuntu2.4
    • 1.0.1f-1ubuntu2.5
    • 1.0.1f-1ubuntu2.7
    • 1.0.1f-1ubuntu2.8
    • 1.0.1f-1ubuntu2.11
    • 1.0.1f-1ubuntu2.12
    • 1.0.1f-1ubuntu2.15
    • 1.0.1f-1ubuntu2.16
    • 1.0.1f-1ubuntu2.17
    • 1.0.1f-1ubuntu2.18
    • 1.0.1f-1ubuntu2.19
    • 1.0.1f-1ubuntu2.20
    • 1.0.1f-1ubuntu2.21
    • 1.0.1f-1ubuntu2.22
    • 1.0.1f-1ubuntu2.23
    • 1.0.1f-1ubuntu2.24
    • 1.0.1f-1ubuntu2.25
    • 1.0.1f-1ubuntu2.26
    • 1.0.1f-1ubuntu2.27
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.0.1f-1ubuntu2.27+esm1

    Actualiza a 1.0.1f-1ubuntu2.27+esm1

  • openssl Ubuntu:16.04:LTS

    Versiones
    • 1.0.2d-0ubuntu1
    • 1.0.2d-0ubuntu2
    • 1.0.2e-1ubuntu1
    • 1.0.2f-2ubuntu1
    • 1.0.2g-1ubuntu2
    • 1.0.2g-1ubuntu3
    • 1.0.2g-1ubuntu4
    • 1.0.2g-1ubuntu4.1
    • 1.0.2g-1ubuntu4.2
    • 1.0.2g-1ubuntu4.4
    • 1.0.2g-1ubuntu4.5
    • 1.0.2g-1ubuntu4.6
    • 1.0.2g-1ubuntu4.8
    • 1.0.2g-1ubuntu4.9
    • 1.0.2g-1ubuntu4.10
    • 1.0.2g-1ubuntu4.11
    • 1.0.2g-1ubuntu4.12
    • 1.0.2g-1ubuntu4.13
    • 1.0.2g-1ubuntu4.14
    • 1.0.2g-1ubuntu4.15
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.0.2g-1ubuntu4.16

    Actualiza a 1.0.2g-1ubuntu4.16

  • openssl Ubuntu:18.04:LTS

    Versiones
    • 1.0.2g-1ubuntu13
    • 1.0.2g-1ubuntu14
    • 1.0.2n-1ubuntu1
    • 1.1.0g-2ubuntu1
    • 1.1.0g-2ubuntu2
    • 1.1.0g-2ubuntu3
    • 1.1.0g-2ubuntu4
    • 1.1.0g-2ubuntu4.1
    • 1.1.0g-2ubuntu4.3
    • 1.1.1-1ubuntu2.1~18.04.1
    • 1.1.1-1ubuntu2.1~18.04.2
    • 1.1.1-1ubuntu2.1~18.04.3
    • 1.1.1-1ubuntu2.1~18.04.4
    • 1.1.1-1ubuntu2.1~18.04.5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.1.1-1ubuntu2.1~18.04.6

    Actualiza a 1.1.1-1ubuntu2.1~18.04.6

  • openssl1.0 Ubuntu:18.04:LTS

    Versiones
    • 1.0.2n-1ubuntu2
    • 1.0.2n-1ubuntu3
    • 1.0.2n-1ubuntu4
    • 1.0.2n-1ubuntu5
    • 1.0.2n-1ubuntu5.1
    • 1.0.2n-1ubuntu5.2
    • 1.0.2n-1ubuntu5.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.0.2n-1ubuntu5.4

    Actualiza a 1.0.2n-1ubuntu5.4

Fuentes originales

Comprueba tu servidor →