CVE-2019-15920
CVE-2019-15920
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
An issue was discovered in the Linux kernel before 5.0.10. SMB2_read in fs/cifs/smb2pdu.c has a use-after-free. NOTE: this was not fixed correctly in 5.0.10; see the 5.0.11 ChangeLog, which documents a memory leak.
CVSS 4.3 · Media · EPSS 1,8% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
n/a
- Versiones
- n/a: Afectada
Sin corrección publicada
linux Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.2.6-1
Actualiza a 5.2.6-1
linux Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.2.6-1
Actualiza a 5.2.6-1
linux Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.2.6-1
Actualiza a 5.2.6-1
linux-azure Ubuntu:18.04:LTS
- Versiones
- 4.15.0-1002.2
- 4.15.0-1003.3
- 4.15.0-1004.4
- 4.15.0-1008.8
- 4.15.0-1009.9
- 4.15.0-1012.12
- 4.15.0-1013.13
- 4.15.0-1014.14
- 4.15.0-1018.18
- 4.15.0-1019.19
- 4.15.0-1021.21
- 4.15.0-1022.23
- 4.15.0-1023.24
- 4.15.0-1025.26
- 4.15.0-1028.29
- 4.15.0-1030.31
- 4.15.0-1031.32
- 4.15.0-1032.33
- 4.15.0-1035.36
- 4.15.0-1036.38
- 4.15.0-1037.39
- 4.18.0-1011.11~18.04.1
- 4.18.0-1013.13~18.04.1
- 4.18.0-1014.14~18.04.1
- 4.18.0-1018.18~18.04.1
- 4.18.0-1019.19~18.04.1
- 4.18.0-1020.20~18.04.1
- 4.18.0-1023.24~18.04.1
- 4.18.0-1024.25~18.04.1
- 4.18.0-1025.27~18.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.0.0-1014.14~18.04.1
Actualiza a 5.0.0-1014.14~18.04.1
linux-hwe Ubuntu:18.04:LTS
- Versiones
- 4.18.0-13.14~18.04.1
- 4.18.0-14.15~18.04.1
- 4.18.0-15.16~18.04.1
- 4.18.0-16.17~18.04.1
- 4.18.0-17.18~18.04.1
- 4.18.0-18.19~18.04.1
- 4.18.0-20.21~18.04.1
- 4.18.0-21.22~18.04.1
- 4.18.0-22.23~18.04.1
- 4.18.0-24.25~18.04.1
- 4.18.0-25.26~18.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.0.0-23.24~18.04.1
Actualiza a 5.0.0-23.24~18.04.1
linux-oem-osp1 Ubuntu:18.04:LTS
- Versiones
- 5.0.0-1010.11
- 5.0.0-1012.13
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.0.0-1015.16
Actualiza a 5.0.0-1015.16
linux-hwe-edge Ubuntu:18.04:LTS
- Versiones
- 5.0.0-15.16~18.04.1
- 5.0.0-16.17~18.04.1
- 5.0.0-17.18~18.04.1
- 5.0.0-19.20~18.04.1
- 5.0.0-20.21~18.04.1
- 5.3.0-19.20~18.04.2
- 5.3.0-22.24~18.04.1
- 5.3.0-23.25~18.04.1
- 5.3.0-23.25~18.04.2
- 5.3.0-24.26~18.04.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.0.10
- https://github.com/torvalds/linux/commit/088aaf17aa79300cab14dbee2569c58cfafd7d6e
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00066.html
- https://security.netapp.com/advisory/ntap-20191004-0001/
- https://nvd.nist.gov/vuln/detail/CVE-2019-15920