CVE-2019-16792
CVE-2019-16792 · HTTP Request Smuggling: Content-Length Sent Twice in Waitress
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Waitress through version 1.3.1 allows request smuggling by sending the Content-Length header twice. Waitress would header fold a double Content-Length header and due to being unable to cast the now comma separated value to an integer would set the Content-Length to 0 internally. If two Content-Length headers are sent in a single request, Waitress would treat the request as having no body, thereby treating the body of the request as a new request in HTTP pipelining. This issue is fixed in Waitress 1.4.0.
CVSS 7.1 · Alta · EPSS 2,0% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
waitress
- Versiones
- ≥ <= 1.3.1, ≤ 1.3.1: Afectada (custom)
Sin corrección publicada
waitress Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.4.1-1
Actualiza a 1.4.1-1
waitress Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.4.1-1
Actualiza a 1.4.1-1
waitress Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.4.1-1
Actualiza a 1.4.1-1
waitress PyPI
- Versiones
- 0.1
- 0.2
- 0.3
- 0.4
- 0.5
- 0.6
- 0.6.1
- 0.7
- 0.8
- 0.8.1
- 0.8.10
- 0.8.11b0
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.6
- 0.8.7
- 0.8.8
- 0.8.9
- 0.9.0
- 0.9.0b0
- 0.9.0b1
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0a1
- 1.0a2
- 1.1.0
- 1.2.0
- 1.2.0b1
- 1.2.0b2
- 1.2.0b3
- 1.2.1
- 1.3.0
- 1.3.0b0
- 1.3.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.4.0
Actualiza a 1.4.0
waitress PyPI
- Versiones
- 0.1
- 0.2
- 0.3
- 0.4
- 0.5
- 0.6
- 0.6.1
- 0.7
- 0.8
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.6
- 0.8.7
- 0.8.8
- 0.8.9
- 0.8.10
- 0.8.11b0
- 0.9.0b0
- 0.9.0b1
- 0.9.0
- 1.0a1
- 1.0a2
- 1.0.0
- 1.0.1
- 1.0.2
- 1.1.0
- 1.2.0b1
- 1.2.0b2
- 1.2.0b3
- 1.2.0
- 1.2.1
- 1.3.0b0
- 1.3.0
- 1.3.1
- Intervalos de versiones afectados
- GIT: < 575994cd42e83fd772a5f7ec98b2c56751bd3f65
- ECOSYSTEM: < 1.4.0
Actualiza a 1.4.0
waitress Ubuntu:16.04:LTS
- Versiones
- 0.8.9-2ubuntu1
- 0.8.10-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
waitress Ubuntu:18.04:LTS
- Versiones
- 1.0.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://docs.pylonsproject.org/projects/waitress/en/latest/#security-fixes
- https://github.com/Pylons/waitress/security/advisories/GHSA-4ppp-gpcr-7qf6
- https://github.com/Pylons/waitress/commit/575994cd42e83fd772a5f7ec98b2c56751bd3f65
- https://lists.debian.org/debian-lts-announce/2022/05/msg00011.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-16792