CVE-2019-18348
CVE-2019-18348
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
An issue was discovered in urllib2 in Python 2.x through 2.7.17 and urllib in Python 3.x through 3.8.0. CRLF injection is possible if the attacker controls a url parameter, as demonstrated by the first argument to urllib.request.urlopen with \r\n (specifically in the host component of a URL) followed by an HTTP header. This is similar to the CVE-2019-9740 query string issue and the CVE-2019-9947 path string issue. (This is not exploitable when glibc has CVE-2016-10739 fixed.). This is fixed in: v2.7.18, v2.7.18rc1; v3.5.10, v3.5.10rc1; v3.6.11, v3.6.11rc1, v3.6.12; v3.7.8, v3.7.8rc1, v3.7.9; v3.8.3, v3.8.3rc1, v3.8.4, v3.8.4rc1, v3.8.5, v3.8.6, v3.8.6rc1.
CVSS 5.4 · Media · EPSS 3,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
n/a
- Versiones
- n/a: Afectada
Sin corrección publicada
python2.7 Debian:11
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.18~rc1-1
Actualiza a 2.7.18~rc1-1
python2.7 Ubuntu:Pro:14.04:LTS
- Versiones
- 2.7.5-8ubuntu3
- 2.7.5-8ubuntu4
- 2.7.6-2
- 2.7.6-2ubuntu1
- 2.7.6-3
- 2.7.6-3ubuntu1
- 2.7.6-4
- 2.7.6-4ubuntu1
- 2.7.6-5
- 2.7.6-7
- 2.7.6-8
- 2.7.6-8ubuntu0.2
- 2.7.6-8ubuntu0.3
- 2.7.6-8ubuntu0.4
- 2.7.6-8ubuntu0.5
- 2.7.6-8ubuntu0.6+esm2
- 2.7.6-8ubuntu0.6+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.6-8ubuntu0.6+esm5
Actualiza a 2.7.6-8ubuntu0.6+esm5
python3.4 Ubuntu:Pro:14.04:LTS
- Versiones
- 3.4~b1-0ubuntu3
- 3.4~b1-4ubuntu4
- 3.4~b1-4ubuntu6
- 3.4~b1-5ubuntu2
- 3.4~b2-1
- 3.4~b3-1ubuntu1
- 3.4~rc1-1build1
- 3.4~rc2-1
- 3.4~rc3-0ubuntu1
- 3.4.0-1
- 3.4.0-2ubuntu1
- 3.4.0-2ubuntu1.1
- 3.4.3-1ubuntu1~14.04.1
- 3.4.3-1ubuntu1~14.04.3
- 3.4.3-1ubuntu1~14.04.4
- 3.4.3-1ubuntu1~14.04.5
- 3.4.3-1ubuntu1~14.04.6
- 3.4.3-1ubuntu1~14.04.7
- 3.4.3-1ubuntu1~14.04.7+esm2
- 3.4.3-1ubuntu1~14.04.7+esm4
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.4.3-1ubuntu1~14.04.7+esm6
Actualiza a 3.4.3-1ubuntu1~14.04.7+esm6
python3.5 Ubuntu:Pro:14.04:LTS
- Versiones
- 3.5.2-2ubuntu0~16.04.4~14.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.5.2-2ubuntu0~16.04.4~14.04.1+esm1
Actualiza a 3.5.2-2ubuntu0~16.04.4~14.04.1+esm1
python2.7 Ubuntu:16.04:LTS
- Versiones
- 2.7.10-4ubuntu1
- 2.7.10-4ubuntu2
- 2.7.11-2
- 2.7.11-3
- 2.7.11-4
- 2.7.11-6
- 2.7.11-7
- 2.7.11-7ubuntu1
- 2.7.12-1~16.04
- 2.7.12-1ubuntu0~16.04.1
- 2.7.12-1ubuntu0~16.04.2
- 2.7.12-1ubuntu0~16.04.3
- 2.7.12-1ubuntu0~16.04.4
- 2.7.12-1ubuntu0~16.04.8
- 2.7.12-1ubuntu0~16.04.9
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.12-1ubuntu0~16.04.11
Actualiza a 2.7.12-1ubuntu0~16.04.11
python3.5 Ubuntu:16.04:LTS
- Versiones
- 3.5.0-3
- 3.5.0-3ubuntu1
- 3.5.1~rc1-2ubuntu1
- 3.5.1-1
- 3.5.1-2
- 3.5.1-3
- 3.5.1-5
- 3.5.1-6ubuntu1
- 3.5.1-6ubuntu2
- 3.5.1-9ubuntu1
- 3.5.1-10
- 3.5.2-2~16.01
- 3.5.2-2~16.04
- 3.5.2-2ubuntu0~16.04.1
- 3.5.2-2ubuntu0~16.04.2
- 3.5.2-2ubuntu0~16.04.3
- 3.5.2-2ubuntu0~16.04.4
- 3.5.2-2ubuntu0~16.04.5
- 3.5.2-2ubuntu0~16.04.8
- 3.5.2-2ubuntu0~16.04.9
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.5.2-2ubuntu0~16.04.10
Actualiza a 3.5.2-2ubuntu0~16.04.10
python2.7 Ubuntu:18.04:LTS
- Versiones
- 2.7.14-2ubuntu2
- 2.7.14-4
- 2.7.14-6
- 2.7.14-7
- 2.7.14-8
- 2.7.15~rc1-1
- 2.7.15~rc1-1ubuntu0.1
- 2.7.15-4ubuntu4~18.04
- 2.7.15-4ubuntu4~18.04.1
- 2.7.15-4ubuntu4~18.04.2
- 2.7.17-1~18.04
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.17-1~18.04ubuntu1
Actualiza a 2.7.17-1~18.04ubuntu1
python3.6 Ubuntu:18.04:LTS
- Versiones
- 3.6.3-1ubuntu1
- 3.6.4~rc1-1
- 3.6.4~rc1-2
- 3.6.4-1
- 3.6.4-2
- 3.6.4-3build1
- 3.6.4-4
- 3.6.5~rc1-1
- 3.6.5-3
- 3.6.6-1~18.04
- 3.6.7-1~18.04
- 3.6.8-1~18.04.1
- 3.6.8-1~18.04.2
- 3.6.8-1~18.04.3
- 3.6.9-1~18.04
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.6.9-1~18.04ubuntu1
Actualiza a 3.6.9-1~18.04ubuntu1
python3.7 Ubuntu:Pro:18.04:LTS
- Versiones
- 3.7.0~a2-1
- 3.7.0~a3-1
- 3.7.0~a3-2
- 3.7.0~a3-3
- 3.7.0~a4-1
- 3.7.0~b1-1
- 3.7.0~b1-1build1
- 3.7.0~b2-1
- 3.7.0~b3-1
- 3.7.0-1~18.04
- 3.7.1-1~18.04
- 3.7.3-2~18.04.1
- 3.7.5-2~18.04
- 3.7.5-2~18.04.4
- 3.7.5-2ubuntu1~18.04.2
- 3.7.5-2ubuntu1~18.04.2+esm1
- 3.7.5-2ubuntu1~18.04.2+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.7.5-2ubuntu1~18.04.2+esm3
Actualiza a 3.7.5-2ubuntu1~18.04.2+esm3
python3.8 Ubuntu:Pro:18.04:LTS
- Versiones
- 3.8.0-3~18.04
- 3.8.0-3~18.04.1
- 3.8.0-3ubuntu1~18.04.2
- 3.8.0-3ubuntu1~18.04.2+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.8.0-3ubuntu1~18.04.2+esm2
Actualiza a 3.8.0-3ubuntu1~18.04.2+esm2
python3.8 Ubuntu:20.04:LTS
- Versiones
- 3.8.0-1
- 3.8.0-2
- 3.8.0-3
- 3.8.0-4
- 3.8.0-5
- 3.8.1-2ubuntu3
- 3.8.2~rc1-1ubuntu1
- 3.8.2-1
- 3.8.2-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.8.2-1ubuntu1.1
Actualiza a 3.8.2-1ubuntu1.1
Fuentes originales
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/M34WOYCDKTDE5KLUACE2YIEH7D37KHRX/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JCPGLTTOBB3QEARDX4JOYURP6ELNNA2V/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4X3HW5JRZ7GCPSR7UHJOLD7AWLTQCDVR/
- https://usn.ubuntu.com/4333-1/
- https://usn.ubuntu.com/4333-2/
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00041.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UESGYI5XDAHJBATEZN3MHNDUBDH47AS6/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/A5NSAX4SC3V64PGZUPH7PRDLSON34Q5A/
- https://lists.debian.org/debian-lts-announce/2020/07/msg00011.html
- https://www.oracle.com/security-alerts/cpuoct2020.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1727276
- https://bugs.python.org/issue30458#msg347282
- https://security.netapp.com/advisory/ntap-20191107-0004/
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-18348