CVE-2020-11029
CVE-2020-11029 · Cross-site scripting in stats method (object cache) in WordPress
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
In affected versions of WordPress, a vulnerability in the stats() method of class-wp-object-cache.php can be exploited to execute cross-site scripting (XSS) attacks. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
CVSS 5.8 · Media · EPSS 2,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
wordpress
- Versiones
- >= 5.4.0, < 5.4.1: Afectada
- >= 5.3.0, < 5.3.3: Afectada
- >= 5.2.0, < 5.2.6: Afectada
- >= 5.1.0, < 5.1.5: Afectada
- >= 5.0.0, < 5.0.9: Afectada
- >= 4.9.0, < 4.9.14: Afectada
- >= 4.8.0, < 4.8.13: Afectada
- >= 4.7.0, < 4.7.17: Afectada
- >= 4.6.0, < 4.6.18: Afectada
- >= 4.5.0, < 4.5.21: Afectada
- >= 4.4.0, < 4.4.22: Afectada
- >= 4.3.0, < 4.3.23: Afectada
- >= 4.2.0, < 4.2.27: Afectada
- >= 4.1.0, < 4.1.30: Afectada
- >= 4.0.0, < 4.0.30: Afectada
- >= 3.9.0, < 3.9.31: Afectada
- >= 3.8.0, < 3.8.33: Afectada
- >= 3.7.0, < 3.7.33: Afectada
Sin corrección publicada
wordpress Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.4.1+dfsg1-1
Actualiza a 5.4.1+dfsg1-1
wordpress Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.4.1+dfsg1-1
Actualiza a 5.4.1+dfsg1-1
wordpress Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.4.1+dfsg1-1
Actualiza a 5.4.1+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versiones
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
wordpress Ubuntu:18.04:LTS
- Versiones
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
wordpress Ubuntu:20.04:LTS
- Versiones
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
wordpress Ubuntu:22.04:LTS
- Versiones
- 5.7.1+dfsg1-2ubuntu1
- 5.8.1+dfsg1-2ubuntu1
- 5.8.2+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
wordpress Ubuntu:24.04:LTS
- Versiones
- 6.2+dfsg1-1ubuntu1
- 6.4.3+dfsg1-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
wordpress Ubuntu:25.10
- Versiones
- 6.7.2+dfsg1-1.1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
wordpress Ubuntu:26.10
- Versiones
- 6.7.2+dfsg1-1.1ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
wordpress Ubuntu:26.04:LTS
- Versiones
- 6.7.2+dfsg1-1.1ubuntu1
- 6.7.2+dfsg1-1.1ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://wordpress.org/support/wordpress-version/version-5-4-1/#security-updates
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-568w-8m88-8g2c
- https://www.debian.org/security/2020/dsa-4677
- https://lists.debian.org/debian-lts-announce/2020/05/msg00011.html
- https://nvd.nist.gov/vuln/detail/CVE-2020-11029