p PatchFirst

CVE-2020-11039

CVE-2020-11039 · Integer Overflow in FreeRDP

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

In FreeRDP less than or equal to 2.0.0, when using a manipulated server with USB redirection enabled (nearly) arbitrary memory can be read and written due to integer overflows in length checks. This has been patched in 2.1.0.

CVSS 8.0 · Alta · EPSS 1,1% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • freerdp

    Versiones
    • <= 2.0.0: Afectada

    Sin corrección publicada

  • freerdp2 Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.1.1+dfsg1-1

    Actualiza a 2.1.1+dfsg1-1

  • freerdp Ubuntu:16.04:LTS

    Versiones
    • 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1
    • 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.2
    • 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.3
    • 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • freerdp2 Ubuntu:18.04:LTS

    Versiones
    • 2.0.0~git20170725.1.1648deb+dfsg1-1
    • 2.0.0~git20170725.1.1648deb+dfsg1-5
    • 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu1
    • 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu2
    • 2.0.0~git20170725.1.1648deb+dfsg1-6
    • 2.0.0~git20170725.1.1648deb+dfsg1-6build1
    • 2.0.0~git20170725.1.1648deb+dfsg1-7
    • 2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.1.1+dfsg1-0ubuntu0.18.04.1

    Actualiza a 2.1.1+dfsg1-0ubuntu0.18.04.1

  • freerdp Ubuntu:18.04:LTS

    Versiones
    • 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1
    • 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1
    • 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • freerdp2 Ubuntu:20.04:LTS

    Versiones
    • 2.0.0~git20190204.1.2693389a+dfsg1-1
    • 2.0.0~git20190204.1.2693389a+dfsg1-2
    • 2.0.0~git20190204.1.2693389a+dfsg1-2build1
    • 2.0.0~git20190204.1.2693389a+dfsg1-2build2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.1.1+dfsg1-0ubuntu0.20.04.1

    Actualiza a 2.1.1+dfsg1-0ubuntu0.20.04.1

Fuentes originales

Comprueba tu servidor →