CVE-2020-11042
CVE-2020-11042 · Out-of-bounds Read in FreeRDP
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
In FreeRDP greater than 1.1 and before 2.0.0, there is an out-of-bounds read in update_read_icon_info. It allows reading a attacker-defined amount of client memory (32bit unsigned -> 4GB) to an intermediate buffer. This can be used to crash the client or store information for later retrieval. This has been patched in 2.0.0.
CVSS 5.5 · Media · EPSS 1,8% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
freerdp
- Versiones
- > 1.1, < 2.0.0: Afectada
Sin corrección publicada
freerdp2 Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.1+dfsg1-1
Actualiza a 2.1.1+dfsg1-1
freerdp Ubuntu:16.04:LTS
- Versiones
- 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1
- 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.2
- 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.4
Actualiza a 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.4
freerdp Ubuntu:18.04:LTS
- Versiones
- 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1
- 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.2
Actualiza a 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.2
freerdp2 Ubuntu:18.04:LTS
- Versiones
- 2.0.0~git20170725.1.1648deb+dfsg1-1
- 2.0.0~git20170725.1.1648deb+dfsg1-5
- 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu1
- 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu2
- 2.0.0~git20170725.1.1648deb+dfsg1-6
- 2.0.0~git20170725.1.1648deb+dfsg1-6build1
- 2.0.0~git20170725.1.1648deb+dfsg1-7
- 2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.1+dfsg1-0ubuntu0.18.04.1
Actualiza a 2.1.1+dfsg1-0ubuntu0.18.04.1
freerdp2 Ubuntu:20.04:LTS
- Versiones
- 2.0.0~git20190204.1.2693389a+dfsg1-1
- 2.0.0~git20190204.1.2693389a+dfsg1-2
- 2.0.0~git20190204.1.2693389a+dfsg1-2build1
- 2.0.0~git20190204.1.2693389a+dfsg1-2build2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.1+dfsg1-0ubuntu0.20.04.1
Actualiza a 2.1.1+dfsg1-0ubuntu0.20.04.1
Fuentes originales
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-9jp6-5vf2-cx2q
- https://github.com/FreeRDP/FreeRDP/issues/6010
- https://github.com/FreeRDP/FreeRDP/commit/6b2bc41935e53b0034fe5948aeeab4f32e80f30f
- https://usn.ubuntu.com/4379-1/
- https://usn.ubuntu.com/4382-1/
- https://lists.debian.org/debian-lts-announce/2020/08/msg00054.html
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
- https://nvd.nist.gov/vuln/detail/CVE-2020-11042