CVE-2020-11058
CVE-2020-11058 · Improper Restriction of Operations within the Bounds of a Memory Buffer in FreeRDP
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
In FreeRDP after 1.1 and before 2.0.0, a stream out-of-bounds seek in rdp_read_font_capability_set could lead to a later out-of-bounds read. As a result, a manipulated client or server might force a disconnect due to an invalid data read. This has been fixed in 2.0.0.
CVSS 2.2 · Baja · EPSS 1,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
freerdp
- Versiones
- > 1.1, < 2.0.0: Afectada
Sin corrección publicada
freerdp2 Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.1+dfsg1-1
Actualiza a 2.1.1+dfsg1-1
freerdp Ubuntu:16.04:LTS
- Versiones
- 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1
- 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.2
- 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.4
Actualiza a 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.4
freerdp Ubuntu:18.04:LTS
- Versiones
- 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1
- 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.2
Actualiza a 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.2
freerdp2 Ubuntu:18.04:LTS
- Versiones
- 2.0.0~git20170725.1.1648deb+dfsg1-1
- 2.0.0~git20170725.1.1648deb+dfsg1-5
- 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu1
- 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu2
- 2.0.0~git20170725.1.1648deb+dfsg1-6
- 2.0.0~git20170725.1.1648deb+dfsg1-6build1
- 2.0.0~git20170725.1.1648deb+dfsg1-7
- 2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.1+dfsg1-0ubuntu0.18.04.1
Actualiza a 2.1.1+dfsg1-0ubuntu0.18.04.1
freerdp2 Ubuntu:20.04:LTS
- Versiones
- 2.0.0~git20190204.1.2693389a+dfsg1-1
- 2.0.0~git20190204.1.2693389a+dfsg1-2
- 2.0.0~git20190204.1.2693389a+dfsg1-2build1
- 2.0.0~git20190204.1.2693389a+dfsg1-2build2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.1+dfsg1-0ubuntu0.20.04.1
Actualiza a 2.1.1+dfsg1-0ubuntu0.20.04.1
Fuentes originales
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-wjg2-2f82-466g
- https://github.com/FreeRDP/FreeRDP/issues/6011
- https://github.com/FreeRDP/FreeRDP/commit/3627aaf7d289315b614a584afb388f04abfb5bbf
- https://usn.ubuntu.com/4379-1/
- https://usn.ubuntu.com/4382-1/
- https://lists.debian.org/debian-lts-announce/2020/08/msg00054.html
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
- https://nvd.nist.gov/vuln/detail/CVE-2020-11058