CVE-2020-11066
CVE-2020-11066 · Improperly Controlled Modification of Dynamically-Determined Object Attributes in TYPO3 CMS
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
In TYPO3 CMS greater than or equal to 9.0.0 and less than 9.5.17 and greater than or equal to 10.0.0 and less than 10.4.2, calling unserialize() on malicious user-submitted content can lead to modification of dynamically-determined object attributes and result in triggering deletion of an arbitrary directory in the file system, if it is writable for the web server. It can also trigger message submission via email using the identity of the web site (mail relay). Another insecure deserialization vulnerability is required to actually exploit mentioned aspects. This has been fixed in 9.5.17 and 10.4.2.
CVSS 8.7 · Alta · EPSS 1,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
typo3 cms
- Versiones
- >= 9.0.0, < 9.5.17: Afectada
- >= 10.0.0, < 10.4.2: Afectada
Sin corrección publicada
typo3/cms-core Packagist
- Versiones
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- v9.5.10
- v9.5.11
- v9.5.12
- v9.5.13
- v9.5.14
- v9.5.15
- v9.5.16
- v9.5.2
- v9.5.3
- v9.5.4
- v9.5.5
- v9.5.6
- v9.5.7
- v9.5.8
- v9.5.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 9.0.0, < 9.5.17
Actualiza a 9.5.17
typo3/cms-core Packagist
- Versiones
- v10.0.0
- v10.1.0
- v10.2.0
- v10.2.1
- v10.2.2
- v10.3.0
- v10.4.0
- v10.4.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 10.0.0, < 10.4.2
Actualiza a 10.4.2
typo3/cms Packagist
- Versiones
- v10.0.0
- v10.1.0
- v10.2.0
- v10.2.1
- v10.2.2
- v10.3.0
- v10.4.0
- v10.4.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 10.0.0, < 10.4.2
Actualiza a 10.4.2
typo3/cms Packagist
- Versiones
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- v9.5.10
- v9.5.11
- v9.5.12
- v9.5.13
- v9.5.14
- v9.5.15
- v9.5.16
- v9.5.2
- v9.5.3
- v9.5.4
- v9.5.5
- v9.5.6
- v9.5.7
- v9.5.8
- v9.5.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 9.0.0, < 9.5.17
Actualiza a 9.5.17