CVE-2020-11078
CVE-2020-11078 · CRLF injection in httplib2
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
In httplib2 before version 0.18.0, an attacker controlling unescaped part of uri for `httplib2.Http.request()` could change request headers and body, send additional hidden requests to same server. This vulnerability impacts software that uses httplib2 with uri constructed by string concatenation, as opposed to proper urllib building with escaping. This has been fixed in 0.18.0.
CVSS 6.8 · Media · EPSS 2,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
httplib2
- Versiones
- < 0.81.0: Afectada
Sin corrección publicada
python-httplib2 Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.18.1-1
Actualiza a 0.18.1-1
python-httplib2 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.18.1-1
Actualiza a 0.18.1-1
python-httplib2 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.18.1-1
Actualiza a 0.18.1-1
httplib2 PyPI
- Versiones
- 0.10.3
- 0.11.0
- 0.11.1
- 0.11.3
- 0.12.0
- 0.12.1
- 0.12.3
- 0.13.0
- 0.13.1
- 0.14.0
- 0.15.0
- 0.16.0
- 0.17.0
- 0.17.1
- 0.17.2
- 0.17.3
- 0.17.4
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.7.4
- 0.7.5
- 0.7.6
- 0.7.7
- 0.8
- 0.9
- 0.9.1
- 0.9.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.18.0
Actualiza a 0.18.0
httplib2 PyPI
- Versiones
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.7.4
- 0.7.5
- 0.7.6
- 0.7.7
- 0.8
- 0.9
- 0.9.1
- 0.9.2
- 0.10.3
- 0.11.0
- 0.11.1
- 0.11.3
- 0.12.0
- 0.12.1
- 0.12.3
- 0.13.0
- 0.13.1
- 0.14.0
- 0.15.0
- 0.16.0
- 0.17.0
- 0.17.1
- 0.17.2
- 0.17.3
- 0.17.4
- Intervalos de versiones afectados
- GIT: < a1457cc31f3206cf691d11d2bf34e98865873e9e
- ECOSYSTEM: < 0.18.0
Actualiza a 0.18.0
python-httplib2 Ubuntu:14.04:LTS
- Versiones
- 0.8-2
- 0.8-2build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-httplib2 Ubuntu:16.04:LTS
- Versiones
- 0.9+dfsg-2
- 0.9.1+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-httplib2 Ubuntu:18.04:LTS
- Versiones
- 0.9.2+dfsg-1
- 0.9.2+dfsg-1ubuntu0.1
- 0.9.2+dfsg-1ubuntu0.2
- 0.9.2+dfsg-1ubuntu0.3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-httplib2 Ubuntu:20.04:LTS
- Versiones
- 0.11.3-2
- 0.11.3-2build1
- 0.14.0-1
- 0.14.0-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/httplib2/httplib2/security/advisories/GHSA-gg84-qgv9-w4pq
- https://github.com/httplib2/httplib2/commit/a1457cc31f3206cf691d11d2bf34e98865873e9e
- https://lists.apache.org/thread.html/rc9eff9572946142b657c900fe63ea4bbd3535911e8d4ce4d08fe4b89%40%3Ccommits.allura.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2020/06/msg00000.html
- https://lists.apache.org/thread.html/r23711190c2e98152cb6f216b95090d5eeb978543bb7e0bad22ce47fc%40%3Cissues.beam.apache.org%3E
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IXCX2AWROGWGY5GXR7VN3BKF34A2FO6J/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PZJ3D6JSM7CFZESZZKGUW2VX55BOSOXI/
- https://lists.apache.org/thread.html/r69a462e690b5f2c3d418a288a2c98ae764d58587bd0b5d6ab141f25f%40%3Cissues.beam.apache.org%3E
- https://lists.apache.org/thread.html/rad8872fc99f670958c2774e2bf84ee32a3a0562a0c787465cf3dfa23%40%3Cissues.beam.apache.org%3E
- https://lists.apache.org/thread.html/r7f364000066748299b331b615ba51c62f55ab5b201ddce9a22d98202%40%3Cissues.beam.apache.org%3E
- https://lists.apache.org/thread.html/r4d35dac106fab979f0db75a07fc4e320ad848b722103e79667ff99e1%40%3Cissues.beam.apache.org%3E
- https://nvd.nist.gov/vuln/detail/CVE-2020-11078