CVE-2020-26255
CVE-2020-26255 · PHP Phar archives could be uploaded and executed in Kirby
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Kirby is a CMS. In Kirby CMS (getkirby/cms) before version 3.4.5, and Kirby Panel before version 2.5.14 , an editor with full access to the Kirby Panel can upload a PHP .phar file and execute it on the server. This vulnerability is critical if you might have potential attackers in your group of authenticated Panel users, as they can gain access to the server with such a Phar file. Visitors without Panel access *cannot* use this attack vector. The problem has been patched in Kirby 2.5.14 and Kirby 3.4.5. Please update to one of these or a later version to fix the vulnerability. Note: Kirby 2 reaches end of life on December 31, 2020. We therefore recommend to upgrade your Kirby 2 sites to Kirby 3. If you cannot upgrade, we still recommend to update to Kirby 2.5.14.
CVSS 6.8 · Media · EPSS 1,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
kirby
- Versiones
- < 3.4.5: Afectada
Sin corrección publicada
getkirby/panel Packagist
- Versiones
- 2.4.0
- 2.4.1
- 2.4.2
- 2.5.0
- 2.5.1
- 2.5.10
- 2.5.11
- 2.5.11-RC-1
- 2.5.12
- 2.5.13
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- 2.5.5-RC-1
- 2.5.6
- 2.5.6-RC-1
- 2.5.7
- 2.5.7-RC-1
- 2.5.8
- 2.5.8-RC-1
- 2.5.9
- 2.5.9-RC-1
- 2.5.9-RC-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.5.14
Actualiza a 2.5.14
getkirby/cms Packagist
- Versiones
- 3.0.0
- 3.0.1
- 3.0.1-rc.1
- 3.0.2
- 3.0.2-rc.1
- 3.0.3
- 3.0.3-rc.1
- 3.0.3-rc.2
- 3.0.3-rc.3
- 3.1.0
- 3.1.0-rc.1
- 3.1.1
- 3.1.2
- 3.1.2-rc.1
- 3.1.3
- 3.1.3-rc.1
- 3.1.4
- 3.1.4-rc.1
- 3.2.0
- 3.2.0-rc.1
- 3.2.0-rc.2
- 3.2.0-rc.3
- 3.2.0-rc.4
- 3.2.1
- 3.2.1-rc.1
- 3.2.2
- 3.2.3
- 3.2.3-rc.1
- 3.2.4
- 3.2.4-rc.1
- 3.2.5
- 3.2.5-rc.1
- 3.2.5-rc.2
- 3.3.0
- 3.3.0-rc.1
- 3.3.0-rc.2
- 3.3.0-rc.3
- 3.3.0-rc.4
- 3.3.0-rc.5
- 3.3.1
- 3.3.1-rc.1
- 3.3.2
- 3.3.2-rc.1
- 3.3.3
- 3.3.3-rc.1
- 3.3.4
- 3.3.4-rc.1
- 3.3.5
- 3.3.5-rc.1
- 3.3.6
- 3.4.0
- 3.4.0-rc.1
- 3.4.0-rc.2
- 3.4.0-rc.3
- 3.4.1
- 3.4.1-rc.1
- 3.4.2
- 3.4.3
- 3.4.3-rc.1
- 3.4.4
- 3.4.4-rc.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.0.0, < 3.4.5
Actualiza a 3.4.5
Fuentes originales
- https://packagist.org/packages/getkirby/cms
- https://packagist.org/packages/getkirby/panel
- https://github.com/getkirby/kirby/security/advisories/GHSA-g3h8-cg9x-47qw
- https://github.com/getkirby/kirby/releases/tag/3.4.5
- https://github.com/getkirby/kirby/commit/db8f371b13036861c9cc5ba3e85e27f73fce5e09
- https://github.com/getkirby-v2/panel/commit/5a569d4e3ddaea2b6628d7ec1472a3e8bc410881
- https://nvd.nist.gov/vuln/detail/CVE-2020-26255