CVE-2020-8927
CVE-2020-8927 · Buffer overflow in Brotli library
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
CVSS 5.3 · Media · EPSS 3,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
brotli
- Versiones
- ≥ stable, ≤ 1.0.7: Afectada (custom)
Sin corrección publicada
brotli Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-1
Actualiza a 1.0.9-1
brotli Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-1
Actualiza a 1.0.9-1
brotli Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-1
Actualiza a 1.0.9-1
brotli Ubuntu:16.04:LTS
- Versiones
- 0.2.0+dfsg-1
- 0.3.0+dfsg-1
- 0.3.0+dfsg-2
- 0.3.0+dfsg-2ubuntu1
- 1.0.3-1ubuntu1~16.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.3-1ubuntu1~16.04.2
Actualiza a 1.0.3-1ubuntu1~16.04.2
brotli Ubuntu:18.04:LTS
- Versiones
- 0.6.0-1build1
- 1.0.2-2
- 1.0.2-3
- 1.0.3-1ubuntu1
- 1.0.3-1ubuntu1.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.3-1ubuntu1.3
Actualiza a 1.0.3-1ubuntu1.3
brotli Ubuntu:20.04:LTS
- Versiones
- 1.0.7-2
- 1.0.7-2build1
- 1.0.7-4
- 1.0.7-5
- 1.0.7-6
- 1.0.7-6build1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.7-6ubuntu0.1
Actualiza a 1.0.7-6ubuntu0.1
Fuentes originales
- https://github.com/google/brotli/releases/tag/v1.0.9
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00108.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MMBKACMLSRX7JJSKBTR35UOEP2WFR6QP/
- https://usn.ubuntu.com/4568-1/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WW62OZEY2GHJL4JCOLJRBSRETXDHMWRK/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/J4E265WKWKYMK2RYYSIXBEGZTDY5IQE6/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/M4VCDOJGL6BK3HB4XRD2WETBPYX2ITF6/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/W23CUADGMVMQQNFKHPHXVP7RPZJZNN6I/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/356JOYTWW4BWSZ42SEFLV7NYHL3S3AEH/
- https://lists.debian.org/debian-lts-announce/2020/12/msg00003.html
- https://www.debian.org/security/2020/dsa-4801
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZXEQ3GQVELA2T4HNZG7VPMS2HDVXMJRG/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MQLM7ABVCYJLF6JRPF3M3EBXW63GNC27/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4TOGTZ2ZWDH662ZNFFSZVL3M5AJXV6JF/
- https://nvd.nist.gov/vuln/detail/CVE-2020-8927