CVE-2021-20283
CVE-2021-20283
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
CVSS 4.3 · Media · EPSS 1,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
moodle
- Versiones
- Fixed in 3.10.2, 3.9.5, 3.8.8, 3.5.17: Afectada
Sin corrección publicada
moodle/moodle Packagist
- Versiones
- v3.10.0
- v3.10.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.10.0, < 3.10.2
Actualiza a 3.10.2
moodle/moodle Packagist
- Versiones
- v3.9.0
- v3.9.1
- v3.9.2
- v3.9.3
- v3.9.4
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.9.0, < 3.9.5
Actualiza a 3.9.5
moodle/moodle Packagist
- Versiones
- v3.8.0
- v3.8.1
- v3.8.2
- v3.8.3
- v3.8.4
- v3.8.5
- v3.8.6
- v3.8.7
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.8.0, < 3.8.8
Actualiza a 3.8.8
moodle/moodle Packagist
- Versiones
- v2.3.10
- v2.3.11
- v2.3.4
- v2.3.5
- v2.3.6
- v2.3.7
- v2.3.8
- v2.3.9
- v2.4.0
- v2.4.0-rc1
- v2.4.1
- v2.4.10
- v2.4.11
- v2.4.2
- v2.4.3
- v2.4.4
- v2.4.5
- v2.4.6
- v2.4.7
- v2.4.8
- v2.4.9
- v2.5.0
- v2.5.0-beta
- v2.5.0-rc1
- v2.5.1
- v2.5.2
- v2.5.3
- v2.5.4
- v2.5.5
- v2.5.6
- v2.5.7
- v2.5.8
- v2.5.9
- v2.6.0
- v2.6.0-beta
- v2.6.0-rc1
- v2.6.1
- v2.6.10
- v2.6.11
- v2.6.2
- v2.6.3
- v2.6.4
- v2.6.5
- v2.6.6
- v2.6.7
- v2.6.8
- v2.6.9
- v2.7.0
- v2.7.0-beta
- v2.7.0-rc1
- v2.7.0-rc2
- v2.7.1
- v2.7.10
- v2.7.11
- v2.7.12
- v2.7.13
- v2.7.14
- v2.7.15
- v2.7.16
- v2.7.17
- v2.7.18
- v2.7.19
- v2.7.2
- v2.7.20
- v2.7.3
- v2.7.4
- v2.7.5
- v2.7.6
- v2.7.7
- v2.7.8
- v2.7.9
- v2.8.0
- v2.8.0-beta
- v2.8.0-rc1
- v2.8.0-rc2
- v2.8.1
- v2.8.10
- v2.8.11
- v2.8.12
- v2.8.2
- v2.8.3
- v2.8.4
- v2.8.5
- v2.8.6
- v2.8.7
- v2.8.8
- v2.8.9
- v2.9.0
- v2.9.0-beta
- v2.9.0-rc1
- v2.9.0-rc2
- v2.9.1
- v2.9.2
- v2.9.3
- v2.9.4
- v2.9.5
- v2.9.6
- v2.9.7
- v2.9.8
- v2.9.9
- v3.0.0
- v3.0.0-beta
- v3.0.0-rc1
- v3.0.0-rc2
- v3.0.0-rc3
- v3.0.0-rc4
- v3.0.1
- v3.0.10
- v3.0.2
- v3.0.3
- v3.0.4
- v3.0.5
- v3.0.6
- v3.0.7
- v3.0.8
- v3.0.9
- v3.1.0
- v3.1.0-beta
- v3.1.0-rc1
- v3.1.0-rc2
- v3.1.1
- v3.1.10
- v3.1.11
- v3.1.12
- v3.1.13
- v3.1.14
- v3.1.15
- v3.1.16
- v3.1.17
- v3.1.18
- v3.1.2
- v3.1.3
- v3.1.4
- v3.1.5
- v3.1.6
- v3.1.7
- v3.1.8
- v3.1.9
- v3.2.0
- v3.2.0-beta
- v3.2.0-rc1
- v3.2.0-rc2
- v3.2.0-rc3
- v3.2.0-rc4
- v3.2.0-rc5
- v3.2.1
- v3.2.2
- v3.2.3
- v3.2.4
- v3.2.5
- v3.2.6
- v3.2.7
- v3.2.8
- v3.2.9
- v3.3.0
- v3.3.0-beta
- v3.3.0-rc1
- v3.3.0-rc2
- v3.3.0-rc3
- v3.3.1
- v3.3.2
- v3.3.3
- v3.3.4
- v3.3.5
- v3.3.6
- v3.3.7
- v3.3.8
- v3.3.9
- v3.4.0
- v3.4.0-beta
- v3.4.0-rc1
- v3.4.0-rc2
- v3.4.0-rc3
- v3.4.1
- v3.4.2
- v3.4.3
- v3.4.4
- v3.4.5
- v3.4.6
- v3.4.7
- v3.4.8
- v3.4.9
- v3.5.0
- v3.5.0-beta
- v3.5.0-rc1
- v3.5.1
- v3.5.10
- v3.5.11
- v3.5.12
- v3.5.13
- v3.5.14
- v3.5.15
- v3.5.16
- v3.5.2
- v3.5.3
- v3.5.4
- v3.5.5
- v3.5.6
- v3.5.7
- v3.5.8
- v3.5.9
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.5.17
Actualiza a 3.5.17
moodle Ubuntu:Pro:16.04:LTS
- Versiones
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
moodle Ubuntu:Pro:18.04:LTS
- Versiones
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://bugzilla.redhat.com/show_bug.cgi?id=1939051
- https://moodle.org/mod/forum/discuss.php?d=419654
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AFSNJ7XHVTC52RSRX2GBQFF3VEEAY2MS/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UFH5DDMU5TZ3JT4Q52WMRAHACA5MHIMT/
- https://nvd.nist.gov/vuln/detail/CVE-2021-20283