CVE-2021-21332
CVE-2021-21332 · Cross-site scripting (XSS) vulnerability in the password reset endpoint
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Synapse is a Matrix reference homeserver written in python (pypi package matrix-synapse). Matrix is an ecosystem for open federated Instant Messaging and VoIP. In Synapse before version 1.27.0, the password reset endpoint served via Synapse was vulnerable to cross-site scripting (XSS) attacks. The impact depends on the configuration of the domain that Synapse is deployed on, but may allow access to cookies and other browser data, CSRF vulnerabilities, and access to other resources served on the same domain or parent domains. This is fixed in version 1.27.0.
CVSS 6.9 · Media · EPSS 1,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
synapse
- Versiones
- < 1.27.0: Afectada
Sin corrección publicada
matrix-synapse PyPI
- Versiones
- 0.33.5
- 0.33.5.1
- 0.33.6
- 0.33.6rc1
- 0.33.7
- 0.33.7rc1
- 0.33.7rc2
- 0.33.8
- 0.33.8rc2
- 0.33.9
- 0.34.0
- 0.34.0.1
- 0.34.0rc1
- 0.34.0rc2
- 0.34.1.1
- 0.99.0
- 0.99.0rc1
- 0.99.0rc2
- 0.99.0rc3
- 0.99.0rc4
- 0.99.1
- 0.99.1.1
- 0.99.1rc1
- 0.99.1rc2
- 0.99.2
- 0.99.2rc1
- 0.99.3
- 0.99.3.1
- 0.99.3.2
- 0.99.3rc1
- 0.99.4
- 0.99.4rc1
- 0.99.5
- 0.99.5.1
- 0.99.5.2
- 0.99.5rc1
- 1.0.0
- 1.0.0rc1
- 1.0.0rc2
- 1.0.0rc3
- 1.1.0
- 1.1.0rc1
- 1.1.0rc2
- 1.10.0
- 1.10.0rc1
- 1.10.0rc2
- 1.10.0rc3
- 1.10.0rc5
- 1.10.1
- 1.11.0
- 1.11.0rc1
- 1.11.1
- 1.12.0
- 1.12.0rc1
- 1.12.1
- 1.12.1rc1
- 1.12.2
- 1.12.3
- 1.12.4
- 1.12.4rc1
- 1.13.0
- 1.13.0rc1
- 1.13.0rc2
- 1.13.0rc3
- 1.14.0
- 1.14.0rc1
- 1.14.0rc2
- 1.15.0
- 1.15.0rc1
- 1.15.1
- 1.15.2
- 1.16.0
- 1.16.0rc1
- 1.16.0rc2
- 1.16.1
- 1.17.0
- 1.17.0rc1
- 1.18.0
- 1.18.0rc1
- 1.18.0rc2
- 1.19.0
- 1.19.0rc1
- 1.19.1
- 1.19.1rc1
- 1.19.2
- 1.19.3
- 1.2.0
- 1.2.0rc1
- 1.2.0rc2
- 1.2.1
- 1.20.0
- 1.20.0rc1
- 1.20.0rc2
- 1.20.0rc3
- 1.20.0rc4
- 1.20.0rc5
- 1.20.1
- 1.21.0
- 1.21.0rc1
- 1.21.0rc2
- 1.21.0rc3
- 1.21.1
- 1.21.2
- 1.22.0
- 1.22.0rc1
- 1.22.0rc2
- 1.22.1
- 1.23.0
- 1.23.0rc1
- 1.23.1
- 1.24.0
- 1.24.0rc1
- 1.24.0rc2
- 1.25.0
- 1.25.0rc1
- 1.26.0
- 1.26.0rc1
- 1.26.0rc2
- 1.27.0rc1
- 1.27.0rc2
- 1.3.0
- 1.3.0rc1
- 1.3.1
- 1.4.0
- 1.4.0rc1
- 1.4.0rc2
- 1.4.1
- 1.4.1rc1
- 1.5.0
- 1.5.0rc1
- 1.5.0rc2
- 1.5.1
- 1.6.0
- 1.6.0rc1
- 1.6.0rc2
- 1.6.1
- 1.7.0
- 1.7.0rc1
- 1.7.0rc2
- 1.7.1
- 1.7.2
- 1.7.3
- 1.8.0
- 1.8.0rc1
- 1.9.0
- 1.9.0.dev1
- 1.9.0.dev2
- 1.9.0rc1
- 1.9.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.27.0
Actualiza a 1.27.0
matrix-synapse PyPI
- Versiones
- 0.33.5
- 0.33.5.1
- 0.33.6
- 0.33.6rc1
- 0.33.7
- 0.33.7rc1
- 0.33.7rc2
- 0.33.8
- 0.33.8rc2
- 0.33.9
- 0.34.0
- 0.34.0.1
- 0.34.0rc1
- 0.34.0rc2
- 0.34.1.1
- 0.99.0
- 0.99.0rc1
- 0.99.0rc2
- 0.99.0rc3
- 0.99.0rc4
- 0.99.1
- 0.99.1.1
- 0.99.1rc1
- 0.99.1rc2
- 0.99.2
- 0.99.2rc1
- 0.99.3
- 0.99.3.1
- 0.99.3.2
- 0.99.3rc1
- 0.99.4
- 0.99.4rc1
- 0.99.5
- 0.99.5.1
- 0.99.5.2
- 0.99.5rc1
- 1.0.0
- 1.0.0rc1
- 1.0.0rc2
- 1.0.0rc3
- 1.1.0
- 1.1.0rc1
- 1.1.0rc2
- 1.10.0
- 1.10.0rc1
- 1.10.0rc2
- 1.10.0rc3
- 1.10.0rc5
- 1.10.1
- 1.11.0
- 1.11.0rc1
- 1.11.1
- 1.12.0
- 1.12.0rc1
- 1.12.1
- 1.12.1rc1
- 1.12.2
- 1.12.3
- 1.12.4
- 1.12.4rc1
- 1.13.0
- 1.13.0rc1
- 1.13.0rc2
- 1.13.0rc3
- 1.14.0
- 1.14.0rc1
- 1.14.0rc2
- 1.15.0
- 1.15.0rc1
- 1.15.1
- 1.15.2
- 1.16.0
- 1.16.0rc1
- 1.16.0rc2
- 1.16.1
- 1.17.0
- 1.17.0rc1
- 1.18.0
- 1.18.0rc1
- 1.18.0rc2
- 1.19.0
- 1.19.0rc1
- 1.19.1
- 1.19.1rc1
- 1.19.2
- 1.19.3
- 1.2.0
- 1.2.0rc1
- 1.2.0rc2
- 1.2.1
- 1.20.0
- 1.20.0rc1
- 1.20.0rc2
- 1.20.0rc3
- 1.20.0rc4
- 1.20.0rc5
- 1.20.1
- 1.21.0
- 1.21.0rc1
- 1.21.0rc2
- 1.21.0rc3
- 1.21.1
- 1.21.2
- 1.22.0
- 1.22.0rc1
- 1.22.0rc2
- 1.22.1
- 1.23.0
- 1.23.0rc1
- 1.23.1
- 1.24.0
- 1.24.0rc1
- 1.24.0rc2
- 1.25.0
- 1.25.0rc1
- 1.26.0
- 1.26.0rc1
- 1.26.0rc2
- 1.27.0rc1
- 1.27.0rc2
- 1.3.0
- 1.3.0rc1
- 1.3.1
- 1.4.0
- 1.4.0rc1
- 1.4.0rc2
- 1.4.1
- 1.4.1rc1
- 1.5.0
- 1.5.0rc1
- 1.5.0rc2
- 1.5.1
- 1.6.0
- 1.6.0rc1
- 1.6.0rc2
- 1.6.1
- 1.7.0
- 1.7.0rc1
- 1.7.0rc2
- 1.7.1
- 1.7.2
- 1.7.3
- 1.8.0
- 1.8.0rc1
- 1.9.0
- 1.9.0.dev1
- 1.9.0.dev2
- 1.9.0rc1
- 1.9.1
- Intervalos de versiones afectados
- GIT: < e54746bdf7d5c831eabe4dcea76a7626f1de73df
- ECOSYSTEM: < 1.27.0
Actualiza a 1.27.0
matrix-synapse Ubuntu:Pro:18.04:LTS
- Versiones
- 0.19.2+dfsg-6
- 0.24.0+dfsg-1
- 0.24.0+dfsg-1ubuntu0.1~esm1
- 0.24.0+dfsg-1ubuntu0.1~esm4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
matrix-synapse Ubuntu:Pro:20.04:LTS
- Versiones
- 1.3.0-1
- 1.4.0-1
- 1.5.0-1
- 1.5.1-1
- 1.6.0-1
- 1.6.1-1
- 1.7.0-2
- 1.7.1-1
- 1.7.2-1
- 1.7.3-1
- 1.8.0-1
- 1.9.0-1
- 1.9.1-1
- 1.10.0-1
- 1.10.0-2
- 1.11.0-1
- 1.11.0-1ubuntu0.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/matrix-org/synapse/security/advisories/GHSA-246w-56m2-5899
- https://github.com/matrix-org/synapse/releases/tag/v1.27.0
- https://github.com/matrix-org/synapse/pull/9200
- https://github.com/matrix-org/synapse/commit/e54746bdf7d5c831eabe4dcea76a7626f1de73df
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TNNAJOZNMVMXM6AS7RFFKB4QLUJ4IFEY/
- https://nvd.nist.gov/vuln/detail/CVE-2021-21332