CVE-2021-21336
CVE-2021-21336 · Exposure of Sensitive Information to an Unauthorized Actor in Products.PluggableAuthService ZODBRoleManager
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an information disclosure vulnerability - everyone can list the names of roles defined in the ZODB Role Manager plugin if the site uses this plugin. The problem has been fixed in version 2.6.0. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to 2.6.0 and re-run the buildout, or if you used pip simply do `pip install "Products.PluggableAuthService>=2.6.0"`.
CVSS 6.5 · Media · EPSS 1,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
products.pluggableauthservice
- Versiones
- < 2.6.0: Afectada
Sin corrección publicada
products-pluggableauthservice PyPI
- Versiones
- 1.10.0
- 1.11.0
- 1.11.1
- 1.11.2
- 1.11.3
- 1.5.2
- 1.5.2.1
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.7.0
- 1.7.0b1
- 1.7.0b2
- 1.7.1
- 1.7.2
- 1.7.3
- 1.7.4
- 1.7.5
- 1.7.6
- 1.7.7
- 1.7.8
- 1.8.0
- 1.9.0
- 2.0
- 2.0b1
- 2.0b2
- 2.0b3
- 2.0b4
- 2.0b5
- 2.0b6
- 2.1
- 2.1.1
- 2.2
- 2.2.1
- 2.3
- 2.4
- 2.5
- 2.5.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.6.0
Actualiza a 2.6.0
products-pluggableauthservice PyPI
- Versiones
- 1.5.2
- 1.5.2.1
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.7.0b1
- 1.7.0b2
- 1.7.0
- 1.7.1
- 1.7.2
- 1.7.3
- 1.7.4
- 1.7.5
- 1.7.6
- 1.7.7
- 1.7.8
- 1.8.0
- 1.9.0
- 1.10.0
- 1.11.0
- 1.11.1
- 1.11.2
- 1.11.3
- 2.0b1
- 2.0b2
- 2.0b3
- 2.0b4
- 2.0b5
- 2.0b6
- 2.0
- 2.1
- 2.1.1
- 2.2
- 2.2.1
- 2.3
- 2.4
- 2.5
- 2.5.1
- Intervalos de versiones afectados
- GIT: < 2dad81128250cb2e5d950cddc9d3c0314a80b4bb
- ECOSYSTEM: < 2.6.0
Actualiza a 2.6.0
Fuentes originales
- https://github.com/zopefoundation/Products.PluggableAuthService/security/advisories/GHSA-p75f-g7gx-2r7p
- https://pypi.org/project/Products.PluggableAuthService/
- https://github.com/zopefoundation/Products.PluggableAuthService/commit/2dad81128250cb2e5d950cddc9d3c0314a80b4bb
- http://www.openwall.com/lists/oss-security/2021/05/21/1
- http://www.openwall.com/lists/oss-security/2021/05/22/1
- https://nvd.nist.gov/vuln/detail/CVE-2021-21336