CVE-2021-21370
CVE-2021-21370 · Cross-Site Scripting in Content Preview (CType menu)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1 it has been discovered that content elements of type _menu_ are vulnerable to cross-site scripting when their referenced items get previewed in the page module. A valid backend user account is needed to exploit this vulnerability. This is fixed in versions 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1.
CVSS 5.4 · Media · EPSS 0,9% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
typo3.cms
- Versiones
- >= 7.0.0, <= 7.6.50: Afectada
- >= 8.0.0, <= 8.7.39: Afectada
- >= 9.0.0, <= 9.5.24: Afectada
- >= 10.0.0, <= 10.4.13: Afectada
- >= 11.0.0, <= 11.1.0: Afectada
Sin corrección publicada
typo3/cms-backend Packagist
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 7.0.0, < 7.6.51
Actualiza a 7.6.51
typo3/cms-backend Packagist
- Versiones
- v8.7.10
- v8.7.11
- v8.7.12
- v8.7.13
- v8.7.14
- v8.7.15
- v8.7.16
- v8.7.17
- v8.7.18
- v8.7.19
- v8.7.20
- v8.7.21
- v8.7.22
- v8.7.23
- v8.7.24
- v8.7.25
- v8.7.26
- v8.7.27
- v8.7.28
- v8.7.29
- v8.7.30
- v8.7.31
- v8.7.32
- v8.7.7
- v8.7.8
- v8.7.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 8.0.0, < 8.7.40
Actualiza a 8.7.40
typo3/cms-backend Packagist
- Versiones
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- v9.5.10
- v9.5.11
- v9.5.12
- v9.5.13
- v9.5.14
- v9.5.15
- v9.5.16
- v9.5.17
- v9.5.18
- v9.5.19
- v9.5.2
- v9.5.20
- v9.5.21
- v9.5.22
- v9.5.23
- v9.5.24
- v9.5.3
- v9.5.4
- v9.5.5
- v9.5.6
- v9.5.7
- v9.5.8
- v9.5.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 9.0.0, < 9.5.25
Actualiza a 9.5.25
typo3/cms-backend Packagist
- Versiones
- v10.0.0
- v10.1.0
- v10.2.0
- v10.2.1
- v10.2.2
- v10.3.0
- v10.4.0
- v10.4.1
- v10.4.10
- v10.4.11
- v10.4.12
- v10.4.13
- v10.4.2
- v10.4.3
- v10.4.4
- v10.4.5
- v10.4.6
- v10.4.7
- v10.4.8
- v10.4.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 10.0.0, < 10.4.14
Actualiza a 10.4.14
typo3/cms-backend Packagist
- Versiones
- v11.0.0
- v11.1.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 11.0.0, < 11.1.1
Actualiza a 11.1.1
typo3/cms-core Packagist
- Versiones
- v10.0.0
- v10.1.0
- v10.2.0
- v10.2.1
- v10.2.2
- v10.3.0
- v10.4.0
- v10.4.1
- v10.4.10
- v10.4.11
- v10.4.12
- v10.4.13
- v10.4.2
- v10.4.3
- v10.4.4
- v10.4.5
- v10.4.6
- v10.4.7
- v10.4.8
- v10.4.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 10.0.0, < 10.4.14
Actualiza a 10.4.14
typo3/cms-core Packagist
- Versiones
- v11.0.0
- v11.1.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 11.0.0, < 11.1.1
Actualiza a 11.1.1
typo3/cms-core Packagist
- Versiones
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- v9.5.10
- v9.5.11
- v9.5.12
- v9.5.13
- v9.5.14
- v9.5.15
- v9.5.16
- v9.5.17
- v9.5.18
- v9.5.19
- v9.5.2
- v9.5.20
- v9.5.21
- v9.5.22
- v9.5.23
- v9.5.24
- v9.5.3
- v9.5.4
- v9.5.5
- v9.5.6
- v9.5.7
- v9.5.8
- v9.5.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 9.0.0, < 9.5.25
Actualiza a 9.5.25
typo3/cms Packagist
- Versiones
- v10.0.0
- v10.1.0
- v10.2.0
- v10.2.1
- v10.2.2
- v10.3.0
- v10.4.0
- v10.4.1
- v10.4.10
- v10.4.11
- v10.4.12
- v10.4.13
- v10.4.2
- v10.4.3
- v10.4.4
- v10.4.5
- v10.4.6
- v10.4.7
- v10.4.8
- v10.4.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 10.0.0, < 10.4.14
Actualiza a 10.4.14
typo3/cms Packagist
- Versiones
- v11.0.0
- v11.1.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 11.0.0, < 11.1.1
Actualiza a 11.1.1
typo3/cms Packagist
- Versiones
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- v9.5.10
- v9.5.11
- v9.5.12
- v9.5.13
- v9.5.14
- v9.5.15
- v9.5.16
- v9.5.17
- v9.5.18
- v9.5.19
- v9.5.2
- v9.5.20
- v9.5.21
- v9.5.22
- v9.5.23
- v9.5.24
- v9.5.3
- v9.5.4
- v9.5.5
- v9.5.6
- v9.5.7
- v9.5.8
- v9.5.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 9.0.0, < 9.5.25
Actualiza a 9.5.25