CVE-2021-22880
CVE-2021-22880
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS) vulnerability. Carefully crafted input can cause the input validation in the `money` type of the PostgreSQL adapter in Active Record to spend too much time in a regular expression, resulting in the potential for a DoS attack. This only impacts Rails applications that are using PostgreSQL along with money type columns that take user input.
CVSS 7.5 · Alta · EPSS 4,4% · Código de explotación público · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
https://github.com/rails/rails
- Versiones
- Fixed in 6.1.2.1, 6.0.3.5, 5.2.4.5: Afectada
Sin corrección publicada
rails Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:6.0.3.5+dfsg-1
Actualiza a 2:6.0.3.5+dfsg-1
rails Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:6.0.3.5+dfsg-1
Actualiza a 2:6.0.3.5+dfsg-1
rails Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:6.0.3.5+dfsg-1
Actualiza a 2:6.0.3.5+dfsg-1
rails Ubuntu:Pro:16.04:LTS
- Versiones
- 2:4.1.10-1
- 2:4.2.5-1
- 2:4.2.5.1-1
- 2:4.2.5.2-2
- 2:4.2.6-1
- 2:4.2.6-1ubuntu0.1~esm1
- 2:4.2.6-1ubuntu0.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:Pro:18.04:LTS
- Versiones
- 2:4.2.9-2
- 2:4.2.9-4
- 2:4.2.10-0ubuntu4
- 2:4.2.10-0ubuntu4+esm1
- 2:4.2.10-0ubuntu4+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:Pro:20.04:LTS
- Versiones
- 2:5.2.2.1+dfsg-1ubuntu1
- 2:5.2.3+dfsg-3
- 2:5.2.3+dfsg-3ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:Pro:22.04:LTS
- Versiones
- 2:6.0.3.7+dfsg-2
- 2:6.1.4.1+dfsg-8ubuntu2
- 2:6.1.4.1+dfsg-8ubuntu2+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:24.04:LTS
- Versiones
- 2:6.1.7.3+dfsg-2build1
- 2:6.1.7.3+dfsg-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:25.10
- Versiones
- 2:6.1.7.3+dfsg-7
- 2:7.2.2.1+dfsg-7
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:26.10
- Versiones
- 2:7.2.3+dfsg-2
- 2:7.2.3.2+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:26.04:LTS
- Versiones
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-2
- 2:7.2.3+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://hackerone.com/reports/1023899
- https://discuss.rubyonrails.org/t/cve-2021-22880-possible-dos-vulnerability-in-active-record-postgresql-adapter/77129
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XQ3NS4IBYE2I3MVMGAHFZBZBIZGHXHT3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MO5OJ3F4ZL3UXVLJO6ECANRVZBNRS2IH/
- https://www.debian.org/security/2021/dsa-4929
- https://security.netapp.com/advisory/ntap-20210805-0009/
- https://nvd.nist.gov/vuln/detail/CVE-2021-22880