p PatchFirst

CVE-2021-26813

CVE-2021-26813

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

markdown2 >=1.0.1.18, fixed in 2.4.0, is affected by a regular expression denial of service vulnerability. If an attacker provides a malicious string, it can make markdown2 processing difficult or delayed for an extended period of time.

CVSS 8.7 · Alta · EPSS 2,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • n/a

    Versiones
    • n/a: Afectada

    Sin corrección publicada

  • python-markdown2 Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.3.10-1.1

    Actualiza a 2.3.10-1.1

  • python-markdown2 Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.3.10-1.1

    Actualiza a 2.3.10-1.1

  • python-markdown2 Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.3.10-1.1

    Actualiza a 2.3.10-1.1

  • markdown2 PyPI

    Versiones
    • 1.0.1.18
    • 1.0.1.19
    • 1.1.0
    • 1.1.1
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.3.0
    • 2.3.1
    • 2.3.10
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.3.5
    • 2.3.6
    • 2.3.7
    • 2.3.8
    • 2.3.9
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.1.18, < 2.4.0

    Actualiza a 2.4.0

  • markdown2 PyPI

    Versiones
    • 1.0.1.18
    • 1.0.1.19
    • 1.1.0
    • 1.1.1
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.3.5
    • 2.3.6
    • 2.3.7
    • 2.3.8
    • 2.3.9
    • 2.3.10
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.1.18, < 2.4.0

    Actualiza a 2.4.0

  • python-markdown2 Ubuntu:20.04:LTS

    Versiones
    • 2.3.7-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • python-markdown2 Ubuntu:22.04:LTS

    Versiones
    • 2.3.10-1.1
    • 2.4.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • python-markdown2 Ubuntu:24.04:LTS

    Versiones
    • 2.4.1-1
    • 2.4.11-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • python-markdown2 Ubuntu:25.10

    Versiones
    • 2.4.11-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • python-markdown2 Ubuntu:26.10

    Versiones
    • 2.5.4-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • python-markdown2 Ubuntu:26.04:LTS

    Versiones
    • 2.4.11-1
    • 2.5.4-2
    • 2.5.4-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →