CVE-2021-30661
CVE-2021-30661
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.
A use after free issue was addressed with improved memory management. This issue is fixed in Safari 14.1, iOS 12.5.3, iOS 14.5 and iPadOS 14.5, watchOS 7.4, tvOS 14.5, macOS Big Sur 11.3. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited..
CVSS 8.8 · Alta · EPSS 4,5% · En el catálogo KEV · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
ios and ipados
- Versiones
- ≥ unspecified, < 14.5: Afectada (custom)
Actualiza a 14.5
safari
- Versiones
- ≥ unspecified, < 14.1: Afectada (custom)
Actualiza a 14.1
tvos
- Versiones
- ≥ unspecified, < 14.5: Afectada (custom)
Actualiza a 14.5
watchos
- Versiones
- ≥ unspecified, < 7.4: Afectada (custom)
Actualiza a 7.4
macos
- Versiones
- ≥ unspecified, < 11.3: Afectada (custom)
Actualiza a 11.3
macos
- Versiones
- ≥ unspecified, < 12.5: Afectada (custom)
Actualiza a 12.5
webkit2gtk Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.30.1-1
Actualiza a 2.30.1-1
webkit2gtk Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.30.1-1
Actualiza a 2.30.1-1
webkit2gtk Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.30.1-1
Actualiza a 2.30.1-1
wpewebkit Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.30.0-1
Actualiza a 2.30.0-1
wpewebkit Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.30.0-1
Actualiza a 2.30.0-1
wpewebkit Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.30.0-1
Actualiza a 2.30.0-1
qtwebkit-opensource-src Ubuntu:16.04:LTS
- Versiones
- 5.4.2+dfsg-1ubuntu2.1
- 5.5.1+dfsg-2ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
webkit2gtk Ubuntu:16.04:LTS
- Versiones
- 2.8.5+dfsg1-3
- 2.10.3+dfsg1-1
- 2.10.4+dfsg1-1
- 2.10.5-1
- 2.10.6-1
- 2.10.6-1ubuntu1
- 2.10.8-1ubuntu1
- 2.10.9-1ubuntu1
- 2.12.5-0ubuntu0.16.04.1
- 2.14.2-0ubuntu0.16.04.1
- 2.14.3-0ubuntu0.16.04.1
- 2.14.5-0ubuntu0.16.04.1
- 2.16.1-0ubuntu0.16.04.1
- 2.16.1-0ubuntu0.16.04.2
- 2.16.2-0ubuntu0.16.04.1
- 2.16.3-0ubuntu0.16.04.1
- 2.16.6-0ubuntu0.16.04.1
- 2.18.0-0ubuntu0.16.04.2
- 2.18.3-0ubuntu0.16.04.1
- 2.18.4-0ubuntu0.16.04.1
- 2.18.5-0ubuntu0.16.04.1
- 2.18.6-0ubuntu0.16.04.1
- 2.20.1-0ubuntu0.16.04.1
- 2.20.2-0ubuntu0.16.04.1
- 2.20.3-0ubuntu0.16.04.1
- 2.20.5-0ubuntu0.16.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
qtwebkit-source Ubuntu:16.04:LTS
- Versiones
- 2.3.2-0ubuntu10
- 2.3.2-0ubuntu11
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
webkitgtk Ubuntu:16.04:LTS
- Versiones
- 2.4.9-2ubuntu2
- 2.4.10-0ubuntu1
- 2.4.11-0ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
webkit2gtk Ubuntu:18.04:LTS
- Versiones
- 2.18.0-2
- 2.18.0-2build1
- 2.18.2-1
- 2.18.3-1
- 2.18.4-1
- 2.18.6-1
- 2.19.91-1ubuntu1
- 2.19.92-1
- 2.20.0-1
- 2.20.0-2
- 2.20.0-2ubuntu1
- 2.20.1-1
- 2.20.2-0ubuntu0.18.04.1
- 2.20.3-0ubuntu0.18.04.1
- 2.20.5-0ubuntu0.18.04.1
- 2.22.2-0ubuntu0.18.04.1
- 2.22.2-0ubuntu0.18.04.2
- 2.22.4-0ubuntu0.18.04.1
- 2.22.5-0ubuntu0.18.04.1
- 2.22.6-0ubuntu0.18.04.1
- 2.24.1-0ubuntu0.18.04.1
- 2.24.2-0ubuntu0.18.04.1
- 2.24.4-0ubuntu0.18.04.1
- 2.26.1-0ubuntu0.18.04.1
- 2.26.2-0ubuntu0.18.04.1
- 2.26.3-0ubuntu0.18.04.1
- 2.26.4-0ubuntu0.18.04.1
- 2.28.0-0ubuntu0.18.04.3
- 2.28.1-0ubuntu0.18.04.1
- 2.28.2-0ubuntu0.18.04.1
- 2.28.3-0ubuntu0.18.04.1
- 2.28.4-0ubuntu0.18.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.30.3-0ubuntu0.18.04.1
Actualiza a 2.30.3-0ubuntu0.18.04.1
qtwebkit-opensource-src Ubuntu:18.04:LTS
- Versiones
- 5.9.1+dfsg-5ubuntu1
- 5.9.1+dfsg-5ubuntu3
- 5.212.0~alpha2-5build2
- 5.212.0~alpha2-5build4
- 5.212.0~alpha2-7
- 5.212.0~alpha2-7build2
- 5.212.0~alpha2-7ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
qtwebkit-source Ubuntu:18.04:LTS
- Versiones
- 2.3.2-0ubuntu13
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
webkitgtk Ubuntu:18.04:LTS
- Versiones
- 2.4.11-3
- 2.4.11-3ubuntu2
- 2.4.11-3ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
webkit2gtk Ubuntu:20.04:LTS
- Versiones
- 2.26.1-3
- 2.26.2-1
- 2.26.3-1ubuntu2
- 2.26.4-1ubuntu1
- 2.28.0-1ubuntu2
- 2.28.1-1
- 2.28.2-0ubuntu0.20.04.1
- 2.28.3-0ubuntu0.20.04.1
- 2.28.4-0ubuntu0.20.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.30.3-0ubuntu0.20.04.1
Actualiza a 2.30.3-0ubuntu0.20.04.1
qtwebkit-opensource-src Ubuntu:20.04:LTS
- Versiones
- 5.212.0~alpha3-3
- 5.212.0~alpha3-5
- 5.212.0~alpha3-6
- 5.212.0~alpha3-7
- 5.212.0~alpha4-1
- 5.212.0~alpha4-1ubuntu1
- 5.212.0~alpha4-1ubuntu2
- 5.212.0~alpha4-1ubuntu2.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
wpewebkit Ubuntu:20.04:LTS
- Versiones
- 2.26.3-1
- 2.26.4-1
- 2.26.4-1build1
- 2.28.0-1
- 2.28.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
qtwebkit-opensource-src Ubuntu:22.04:LTS
- Versiones
- 5.212.0~alpha4-12
- 5.212.0~alpha4-13
- 5.212.0~alpha4-14
- 5.212.0~alpha4-14build1
- 5.212.0~alpha4-14ubuntu2
- 5.212.0~alpha4-15ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://support.apple.com/en-us/HT212317
- https://support.apple.com/en-us/HT212323
- https://support.apple.com/en-us/HT212324
- https://support.apple.com/en-us/HT212325
- https://support.apple.com/en-us/HT212341
- https://support.apple.com/en-us/HT212318
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-30661
- https://nvd.nist.gov/vuln/detail/CVE-2021-30661