CVE-2021-32625
CVE-2021-32625 · Redis vulnerability in STRALGO LCS on 32-bit systems
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Redis is an open source (BSD licensed), in-memory data structure store, used as a database, cache, and message broker. An integer overflow bug in Redis version 6.0 or newer, could be exploited using the STRALGO LCS command to corrupt the heap and potentially result with remote code execution. This is a result of an incomplete fix by CVE-2021-29477. The problem is fixed in version 6.2.4 and 6.0.14. An additional workaround to mitigate the problem without patching the redis-server executable is to use ACL configuration to prevent clients from using the STRALGO LCS command. On 64 bit systems which have the fixes of CVE-2021-29477 (6.2.3 or 6.0.13), it is sufficient to make sure that the proto-max-bulk-len config parameter is smaller than 2GB (default is 512MB).
CVSS 7.5 · Alta · EPSS 4,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · database
Productos y versiones afectados
redis
- Versiones
- < 6.0.14: Afectada
- >= 6.2.0, < 6.2.4: Afectada
Sin corrección publicada
redis Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:6.0.14-1
Actualiza a 5:6.0.14-1
redis Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:6.0.14-1
Actualiza a 5:6.0.14-1
redis Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:6.0.14-1
Actualiza a 5:6.0.14-1
redis Ubuntu:Pro:14.04:LTS
- Versiones
- 2:2.6.13-1
- 2:2.6.16-3
- 2:2.8.0-1
- 2:2.8.2-1
- 2:2.8.4-2
- 2:2.8.4-2ubuntu0.2
- 2:2.8.4-2ubuntu0.2+esm1
- 2:2.8.4-2ubuntu0.2+esm2
- 2:2.8.4-2ubuntu0.2+esm3
- 2:2.8.4-2ubuntu0.2+esm4
- 2:2.8.4-2ubuntu0.2+esm5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
redis Ubuntu:Pro:16.04:LTS
- Versiones
- 2:3.0.3-3
- 2:3.0.5-1
- 2:3.0.5-2
- 2:3.0.5-3
- 2:3.0.5-4
- 2:3.0.6-1
- 2:3.0.6-1ubuntu0.2
- 2:3.0.6-1ubuntu0.3
- 2:3.0.6-1ubuntu0.4
- 2:3.0.6-1ubuntu0.4+esm1
- 2:3.0.6-1ubuntu0.4+esm2
- 2:3.0.6-1ubuntu0.4+esm3
- 2:3.0.6-1ubuntu0.4+esm4
- 2:3.0.6-1ubuntu0.4+esm5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/redis/redis/security/advisories/GHSA-46cp-x4x9-6pfq
- https://github.com/redis/redis/releases/tag/6.0.14
- https://github.com/redis/redis/releases/tag/6.2.4
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BHWOF7CBVUGDK3AN6H3BN3VNTH2TDUZZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SN7INTZFE34MIQJO7WDDTIY5LIBGN6GI/
- https://nvd.nist.gov/vuln/detail/CVE-2021-32625