CVE-2021-32627
CVE-2021-32627 · Integer overflow issue with Streams in Redis
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Redis is an open source, in-memory database that persists on disk. In affected versions an integer overflow bug in Redis can be exploited to corrupt the heap and potentially result with remote code execution. The vulnerability involves changing the default proto-max-bulk-len and client-query-buffer-limit configuration parameters to very large values and constructing specially crafted very large stream elements. The problem is fixed in Redis 6.2.6, 6.0.16 and 5.0.14. For users unable to upgrade an additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from modifying the proto-max-bulk-len configuration parameter. This can be done using ACL to restrict unprivileged users from using the CONFIG SET command.
CVSS 7.5 · Alta · EPSS 3,9% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · database
Productos y versiones afectados
redis
- Versiones
- >= 5.0.0, < 5.0.14: Afectada
- >= 6.0.0, < 6.0.16: Afectada
- >= 6.2.0, < 6.2.6: Afectada
Sin corrección publicada
redis Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:6.0.16-1
Actualiza a 5:6.0.16-1
redis Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:6.0.16-1
Actualiza a 5:6.0.16-1
redis Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:6.0.16-1
Actualiza a 5:6.0.16-1
redis Ubuntu:Pro:18.04:LTS
- Versiones
- 4:4.0.1-7
- 4:4.0.2-6
- 4:4.0.2-9
- 5:4.0.5-1
- 5:4.0.6-1
- 5:4.0.6-2
- 5:4.0.7-1
- 5:4.0.8-1
- 5:4.0.8-2
- 5:4.0.9-1
- 5:4.0.9-1ubuntu0.1
- 5:4.0.9-1ubuntu0.2
- 5:4.0.9-1ubuntu0.2+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:4.0.9-1ubuntu0.2+esm3
Actualiza a 5:4.0.9-1ubuntu0.2+esm3
redis Ubuntu:Pro:20.04:LTS
- Versiones
- 5:5.0.5-2build1
- 5:5.0.6-1
- 5:5.0.7-1
- 5:5.0.7-2
- 5:5.0.7-2ubuntu0.1~esm1
- 5:5.0.7-2ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:5.0.7-2ubuntu0.1+esm1
Actualiza a 5:5.0.7-2ubuntu0.1+esm1
Fuentes originales
- https://github.com/redis/redis/commit/f6a40570fa63d5afdd596c78083d754081d80ae3
- https://github.com/redis/redis/security/advisories/GHSA-f434-69fm-g45v
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VL5KXFN3ATM7IIM7Q4O4PWTSRGZ5744Z/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HTYQ5ZF37HNGTZWVNJD3VXP7I6MEEF42/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WR5WKJWXD4D6S3DJCZ56V74ESLTDQRAB/
- https://www.debian.org/security/2021/dsa-5001
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://security.netapp.com/advisory/ntap-20211104-0003/
- https://security.gentoo.org/glsa/202209-17
- https://nvd.nist.gov/vuln/detail/CVE-2021-32627