p PatchFirst

CVE-2021-32682

CVE-2021-32682 · Multiple vulnerabilities leading to RCE

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

elFinder is an open-source file manager for web, written in JavaScript using jQuery UI. Several vulnerabilities affect elFinder 2.1.58. These vulnerabilities can allow an attacker to execute arbitrary code and commands on the server hosting the elFinder PHP connector, even with minimal configuration. The issues were patched in version 2.1.59. As a workaround, ensure the connector is not exposed without authentication.

CVSS 9.8 · Crítica · EPSS 69,9% · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • elfinder

    Versiones
    • = 2.1.58: Afectada

    Sin corrección publicada

  • studio-42/elfinder Packagist

    Versiones
    • 2.0.3
    • 2.0.4
    • 2.0.5
    • 2.0.6
    • 2.0.7
    • 2.0.8
    • 2.0.9
    • 2.1.0
    • 2.1.1
    • 2.1.10
    • 2.1.11
    • 2.1.12
    • 2.1.13
    • 2.1.14
    • 2.1.15
    • 2.1.16
    • 2.1.17
    • 2.1.18
    • 2.1.19
    • 2.1.2
    • 2.1.20
    • 2.1.21
    • 2.1.22
    • 2.1.23
    • 2.1.24
    • 2.1.25
    • 2.1.26
    • 2.1.27
    • 2.1.28
    • 2.1.29
    • 2.1.3
    • 2.1.30
    • 2.1.31
    • 2.1.32
    • 2.1.33
    • 2.1.34
    • 2.1.35
    • 2.1.36
    • 2.1.37
    • 2.1.38
    • 2.1.39
    • 2.1.4
    • 2.1.40
    • 2.1.41
    • 2.1.42
    • 2.1.43
    • 2.1.44
    • 2.1.45
    • 2.1.46
    • 2.1.47
    • 2.1.48
    • 2.1.49
    • 2.1.5
    • 2.1.50
    • 2.1.51
    • 2.1.52
    • 2.1.53
    • 2.1.54
    • 2.1.55
    • 2.1.56
    • 2.1.57
    • 2.1.58
    • 2.1.6
    • 2.1.7
    • 2.1.8
    • 2.1.9
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.1.59

    Actualiza a 2.1.59

Fuentes originales

Comprueba tu servidor →