p PatchFirst

CVE-2021-32711

CVE-2021-32711 · Leak of information via Store-API

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Shopware is an open source eCommerce platform. Versions prior to 6.3.5.1 may leak of information via Store-API. The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. We recommend to update to the current version 6.3.5.1. You can get the update to 6.3.5.1 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. Please check your plugins if you have it in use. Detailed technical information can be found in the upgrade information. https://github.com/shopware/platform/blob/v6.3.5.1/UPGRADE-6.3.md#6351 ### Workarounds For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659 ### For more information https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021

CVSS 9.1 · Crítica · EPSS 1,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • platform

    Versiones
    • < 6.3.5.1: Afectada

    Sin corrección publicada

  • shopware/platform Packagist

    Versiones
    • 6.3.0.0
    • 6.3.0.1
    • 6.3.0.2
    • 6.3.1.0
    • 6.3.1.1
    • 6.3.2.0
    • 6.3.2.1
    • 6.3.3.0
    • 6.3.3.1
    • 6.3.4.0
    • 6.3.4.1
    • 6.3.5.0
    • v6.0.0+ea2
    • v6.1.0
    • v6.1.0-rc1
    • v6.1.0-rc2
    • v6.1.0-rc3
    • v6.1.0-rc4
    • v6.1.1
    • v6.1.2
    • v6.1.3
    • v6.1.4
    • v6.1.5
    • v6.1.6
    • v6.2.0
    • v6.2.0-RC1
    • v6.2.1
    • v6.2.2
    • v6.2.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 6.3.5.1

    Actualiza a 6.3.5.1

Fuentes originales

Comprueba tu servidor →